When I idle inside Orchestrator Website and the Orchestrator Website Timeout

Can we remove the timeout default Orchestrator Website?
When user idle inside Orchestrator Website and I have not to do re-login Orchestrator Website.


Hi @Anggara_Rahmadhani

Timeout of a webpage while not in use is more like a security aspect. May be there is some config file with values to change the timeout value from x to y but eliminating timeout will cause so many other issue in the object context level.

Thank you.

Hi @Jobin_Joy

Do you know where the config file and how to change the timeout value?

Thank you.


I am looking for something similar as in the inline screenshot. But this from my community Edition.

In enterprise level, I believe we have to locate the config on the server machine where Uipath Orcherstrator instance installed.

Thank you.

Hi @Jobin_Joy

I think your suggestion is for studio.
This screenshot in web config for orchestrator

But, I’m not sure the value timeout that can be change.

Yes that is correct. In the previous post, it for studio. I was telling I am looking something similar for orchestrator as well.

May be we should have to look for export assistance from technical support folks to correctly narrow down the settings node in the specific xml config file.

Thank you.

Ok, thank you for suggestion.

Best regards.

For private installations this is done by setting the Auth.Cookie.Expire in the UiPath.Orchestrator.dll.conf in 2020 or newer. Prior to this it would have been found in the Web.conf.

It’s been while, I think in 2019 and earlier there might have been a session timeout configuraton from the Tenant > Settings > Security view, but that is while ago if it was configured like that.

Another option would be to look at the IIS Site settings.

If you are talking about Cloud (Community / Enterprise), I’m not aware of this session timeout being exposed. It might be something you need to connect with Support on.

Hi @codemonkee

I’m trying to change value Auth.Cookie.Expire in the UiPath.Orchestrator.dll.conf. By default, this is set to 30 value it means 30 minutes.

I have done to change value 480 in Auth.Cookie.Expire and clear cache cookies in browser, and then when I test idle inside web orchestrator is still log out the orchestrator before 30 minutes.

Have you restarted UiPath Orchestator IIS Site for the changes to be picked up?

Thank you for your suggestion, I already restart UiPath Orchestrator IIS Site and more than an hour the Orchestrator Website not Timeout anymore

Best Regards.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.