"When I am using Invoke Workflow File", I get error about:- uipath.excel.activities.excelapplicationscope.macrosetting

Hi Team,
@HareeshMR, @Palaniyappan, @prankurJoshi

So I am working on the project module when demands the following:-

  1. I have WorkflowA in which I am doing “Read Cell” activity to get few values from an excel sheet (using workbook approach instead of excel application scope) in variables (val1, val2, val3, val4)
    here all 4 variables are generic types.

  2. Then I am using “If” activity to compare to do the compare logic (which is working fine as I check with message boxes and log messages)

  3. Then, I am using an “INvoke Workflow File Activity” to switch to another workflow (WorkflowB) depending on the conditions using workflow path. But as I do that and execution from Step One I get error:-
    {
    “message”: “Invoke Workflow File: Cannot set unknown member ‘UiPath.Excel.Activities.ExcelApplicationScope.MacroSetting’.”,
    “level”: “Error”,
    “logType”: “Default”,
    “timeStamp”: “12:51:49”,
    “processVersion”: “1.0.0”,
    “jobId”: “MyJobID”,
    “robotName”: “My Robot Name”,
    “machineId”: 0,
    “fileName”: “WorkflowB”
    }

And the flow is stuck with the above error.

I checked by keeping a message boxes and log messages in the WorkflowB as soon as it starts. But none of the messages are executed. So I figure out there is an issue with “Invoke workflow file” activity.

And As per the error, there is some excelapplicationscope issue.

But I am not getting why is it showing excel application scope issue in invoke workflow file activity when I am not using any excel activities here.

Also As per my rest of the projects the Invoke workflow file activity works fine. only this one shows this error.

Please Help.

Thanks and Regards,
@hacky

Can you run the workflow B and check if it is working fine @hacky?

@HareeshMR is right. Please verify the workflow b standalone that it is working fine.

You might have used some macros what are creating a problem.

Thanks,
Prankur

4 Likes

@hareeshME, @PrankurJoshi

As I already mentioned in my post, I have checked WorkflowB separately, so there is nothing wrong in workflowB and also if condition is perfectly fine.

Only issue with invoke workflow file.

If you already have excel packages installed, just try restarting the studio and even the machine once @hacky

@HareeshMR,

I just noticed that there was some excel application scope in WorkflowB (but it was commented.)

And as I saw, in usually excel application scope we do not have MacrosSetting, but in the WorkflowB whenever I use Excel application scope, I get that Mracros option also

I tried to set it to disableAll and also EnableAll but for both same error is comming.

First of all, if the stuff is commented, it should not even consider it.

I don’t understand the above post from you @hacky

Issue resolved? or can you check if the excel you are modifying have some inbuild macros and if so, validate those

@HareeshMR,

It has been resolved, I had used the excel application scope in the comment section in WorkflowB due to which invoke workflow file activity was giving above issue.

Can you explain a bit so that if any one have the same issue, will look into the solution :slight_smile: