Invoke Workflow problem


#1

Hi

Nee some help. I am invoking a workflow file and keep getting this error:

System.ArgumentException: The workbook does not exist
at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I’m not passing it any arguments or anything…I just want it to start. Tried changing names, typing it myself,changing paths…Always the same error

Any idea?

Thank you


#2

Hi @Petar_Soce,
Select the workflow file again. Assign the import argument. it will work.

Regards
Balamurugan


#3

Im not importing anything. I dont need to. The file that I am invoking is reading some excel table and that path is relative…i think it is not executing because of that. The invoked file has its variables stored in some other path…Not all workflows are in the same folder.

Will try/check and let you know

If i’m invoking file, that file has to be in the same folder as the Main workflow??


#4

@Petar_Soce,
Can you please share your workflow?


#5

I’m sorry. It is confidental data


#6

So…I just went through the debugger. It opens the invoked workflow. The invoked workflow is reading excel table with relative path and Robot does not take the relative path of a an invoked file. It takes the path from Main workflov(parent) and since it is not in the same folder it gives me an error. So stupid.


#7

This post helped me solve my problem

Basicly everytime I invoke a workflow I need to assign a path to that workflow.