Weird Issues with orchestrator

Hi all,

Im facing a weird issue where I have a process deployed on production, and once I run it on the Test\Dev server from the studio it works fine, in production once I log into my user and launch it from the orchestrator it works fine too. But once I log out from my user and schedule the process on the orchestrator, I receive no error or exception but it doesn’t work fine, the robot seems to have trouble with send hotkey activity or what?


If we are able to run via studio and also via orchestrator without schedule then we will be able to run a process even when scheduled
Kindly check once whether the right process is tagged while scheduling
Cheers @Faris

1 Like

This is exactly what makes me wonder! It should just take the same actions but no it doesn’t. I’m not sure if someone faced this issue before.

Is it showing any logs
Kindly check once with the option VIEW LOGS for that particular job
Cheers @Faris

I’m not sure if showing the logs would help, it’s already showing me the logs I wrote and it’s executing in the right path, however there seems to be an issue with selector maybe or send hotkey activity, my send hotkey activity is having no target and it works just fine once i run it while logged in or from the studio, but once I log out no it doesn’t. The thing is it’s really hard to troubleshoot this issue because once I watch it executing it works like a charm.

Is send window message property enabled in the property panel of send hot key activity
Because that would help the activity to run in background
Cheers @Faris

I’m not sure exactly and I can’t currently access and tell whether it’s enabled or not but i’ll do tell you once I can, but the thing is I do process two types of requests and each of them have a different processing scenarios, both do have send hotkey activity and i’m only having an issue with only one request type, so the send hotkey should be working fine if it’s just perfect on one of the requests. I read the following text to tell what’s the request status and take the sequence of actions based on that:



We need to validate once the process buddy
If we in debug mode we could be able to find the root cause of the issue
Cheers @Faris

Do you recommend any way of doing that? the process works fine from the studio and manually through the orchestrator but not while logged out, I was thinking of making a recording of the run.

Hi @Faris,

Have you cleared the user session in the windows user before starting the process from the orchestrator?.

Sometimes it won’t click/send hotkeys properly if you’ve the existing user session without simulate click / SendWindowMessage property enbled.

Hello @kuppu_samy,

Could you please clarify more? All I do is close/terminate everything associated with my user and then I logout.

I’ll try to enable SendWindowMessage and deploy it on production and will tell you how that goes.

1 Like

Let’s try this one and see whether it works
Cheers @Faris

Hi @Faris,

Clear the user session from Task Manager - > Users. Clear the user session of target bot user and run it. It will work even if you haven’t enabled the simulate click and sendWindowMessages property.

So should I disconnect the user associated with the robot running this process?

Yes @Faris, Not disconnect, remove the user session from task manager.

Could you give more details @kuppu_samy? I think it already gets removed once you log out of your user and once the robot wants to run a process it logs in, because I can see from the Task Manager > Users that some other robots create a session, disconnect and then it vanishes from the Task manager.

If the user is removed from the task manager, then it’s fine. The option is differs from OS to OS, it’s not a problem. You’re heading on a right direction. Go on :fire:

I am getting same issue @Faris did you find any solution?please help