Wait For Download does not execute "Activity to initiate download" block

Hi all,

I was recently updating a robot to improve the organization & automation methods, and I wanted to use the Wait for Download activity where I used to have a retry scope that attempted to read an Excel file until it succeeded. Unfortunately, it doesn’t look like Wait for Download is going to work for me. The activity inside the “Activity to initiate download” block won’t execute. It doesn’t seem to matter what the activity in the action block is–even message boxes get skipped over. I’m using:

  • UiPath Studio 2020.4.3
  • UiPath.System.Activities v20.10.3

I also tried rolling UiPath.System.Activities back to 2020.4.0, but to no avail. Has anyone else had this problem?

It is working fine for me. My scenario is to download a file from an application to the specific business repository, once the file is downloaded the rest of the workflow has to be executed.
I have followed the steps like below,

  1. Added the download sequence under “Activity to initiate download” section
  2. Business shared folder has been given as “Monitored Folder”
  3. Created a variable with FileInfo data type to retrieve the downloaded file name

it is working fine. Can you please check the scope of the variable you have created?

HI ArockiaRaja, and thanks for your speedy reply. The savedFileInfo variable was a bit of a red herring, as it’s not relevant to the error I’m having (although it is scoped properly). If you take a look at the output panel from my screenshot, you’ll notice that the “Wait for Download” activity executes and closes without executing the “Click Save Options (Click)” activity inside of it. The behavior is the same if I replace the click activity with a log message or message box.

Hi Spencer
any luck with the wait for download activity? ive got the same issue here.
The workflow simply doesnt get through the Wait for Download scope and doesnt execute the activity supposed to trigger the file download.
Double checked the monitored folder doesnt contain a file with the same name of the one to be downloaded.
In my case the trigger activity is a click activity, browser Firefox
Tried with simulate click on and off, no way
Used the default download folder, a custom one written as string into monitored folder textbox, a custom one passed as string variable, no way
its a shame, cause the activity promises to be very useful.
I’m running on 2020.10.4 enterprise Studio. Tried with both 20.10.3 and 20.10.1 system activities, neither working

Hey Dario,
Unfortunately, I was never able to get the activity to work. I was hoping the issue was specific to Studio 2020.4.3 and that our eventual upgrade to 2020.10.4 would fix it, but it looks like that isn’t the case.
The project that I’m working on uses Internet Explorer (I know–our systems are antiquated), and I’ve resorted to a rather clumsy workaround that opens the downloads window, reads the incoming filename, and retries moving the file for about 20 seconds before failing.
This activity really does seem like it would be very useful, so I hope that UiPath addresses this buggy behavior soon.

Hello,

same problem here, on 2020.4.1. We cannot upgrade actually.

@dario.casubolo and @fahuet, I may have inadvertently stumbled upon a solution. I’m in the habit of deleting unnecessary containers to declutter my workflows. Since it makes the most sense to have a single activity in the “Do” scope of the Download File activity, I deleted the “Do” sequence and dropped my click activity into the Download File container.
Wait for Download Does Not Work
However, on a hunch, I brought in a new Download File and dropped the same click activity inside of the existing Do sequence. And it worked!


I tried deleting and recreating the Do sequence a few times to make sure that I could reproduce the error, and I could. Maybe this fix will work for you two as well.

2 Likes

Awesome, this was a solution that worked for me!

Hello,

Wait For Download just not working for me. After the Activity the variable what I use is not set. I get the Object reference not set to an instance of an object exception.

Please help me, what should I do!