"Use Outlook Desktop App" not working

The function is not able to connect to my Outlook Account

Can someone advise?

Hello @RPA_439 ,

Is Outlook installed in your pc? Which version?


Hi @wasea,

yes, Version 2104 (Build 13929.20386 Microsoft Store)

@RPA_439 ,

Can you post a screenshot with how you configured use Outlook account card?
Did you used the default account?
Outlook is open?



Except for the print screen with the error message most helpful would be if you could provide us with the logs (%locaappdata%/UiPath/Logs)


can you run the Repair Tool from Tools for Outlook? Is available on newer studiox versions

In General, i have the feeling that with my Office Version the Integration doesnt work properly, also the excel tool i cant integrate… Maybe because i have an educational license? Idk, For Excel I installed manually but its still not available but yea thats another topic. To repair it manually i need to know where the Exe. file of outlook is stored but i searched for it very long i didnt find it yet…

How do I Open the log file in Commercial StudioX Version? I cant attach the file here

RemoteException wrapping System.Reflection.TargetInvocationException: Property accessor ‘Account’ on object ‘UiPath.Mail.Activities.Business.OutlookApplicationCard’ threw the following exception:‘Cannot detect an Outlook account.’ —> RemoteException wrapping UiPath.Mail.Outlook.OutlookException: Cannot detect an Outlook account.
at UiPath.Mail.Outlook.OutlookAccountWithStoreDetectionService.GetSelectedStoreDisplayName()
at UiPath.Mail.Activities.Business.OutlookApplicationCard.GetAccount()
at UiPath.Mail.Activities.Business.OutlookApplicationCard.get_Account()
— End of inner exception stack trace —
at System.ComponentModel.ReflectPropertyDescriptor.GetValue(Object component)
at System.Activities.Activity.ReflectedInformation…ctor(Activity activity, ReflectedType reflectType)
at System.Activities.NativeActivity.CacheMetadata(NativeActivityMetadata metadata)
at UiPath.Shared.Activities.AsyncTaskNativeActivity.CacheMetadata(NativeActivityMetadata metadata)
at System.Activities.NativeActivity.OnInternalCacheMetadata(Boolean createEmptyBindings)
at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors) at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback) at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)
at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.RobotRunner.d__91.MoveNext()

Did you try to run the repair tool for office from studiox? It’s under Tools tab.
Yes, we had some problems with installers from store or student licenses. Try run the tool and will continue from there

Hi Horia,

I actually have the same issue, and I tried to run the repair tool for office. But it still doesn’t work. Do you have other solutions I can try to solve this problem?

Thank you.