Send Email - Studio X

I can not get this to run. I keep getting the following message

HRESULT:0x80004004 (E_ABORT)

Exception Type: System.Runtime.InteropServices.COMException

My best guess is that is not recognizing my “from email” address, it is Outlook 2016.


Hi @RPANovice1,
Welcome to the forum.

Did you set it up like this?

If not, can you show us the steps you did or share your StudioX project (note: if so, please blur your credentials).
It is easier for us to guide you in the right direction.

I have it set up like that, I am guessing it is probably what I am using as the outlook account. If I am using the wrong version of the outlook account, would that explain, why it wouldn’t run?

I run Outlook 2016 too, so that shouldn’t be the issue. Can you show us your setup? or why do think it has something to do with your sender address?

Some checks you can do:

  • Which UiPath Studio X version are you running?
  • Are your packages up to date> Project > Project settings

It can happen that when you are running community edition and your activities are a beta version they can stop working. I only choose beta or preview versions for testing. For projects use the stable ones.

that version is compatible with UiPath

Give a try to this. Go to task manager and in details tab. Search for outlook instances there and just kill them all, end task. Then open a outlook instance and try running the process again.

Reason, sometimes the stuck outlook thread gets us in this kind of errors, this also happens with other microsoft application sometimes.

This is probably a dumb question, but where is Task Manager?

No question is a dumb question mate!

To open task manager, Press Ctrl+Shift+Esc all three together

Or Search task manager in windows directly.

My fault, I was thinking of a task manager in UIPath. However, I still am getting the same result.