Urgent: Validation Error in invoked workflow

Dear All,

@cornel @Manjuts90 @jibanjyoti @Pablo_Sanchez @Senthilkumar55 @Madhavi @PrankurJoshi @ClaytonM @Divyashreem

I am receiving a validation error in the following workflow:

Solution_Goodman_POC_New.xaml (65.7 KB)

Till now it worked smoothly but I fail to understand why out of the blue I started receiving this error.

can anybody help me resolve it?

Attached here are the related files:

Zalora Sample Invoice_Goodman Project.pdf (50.4 KB)

Untitled.xlsx (8.6 KB)

Temporary.xlsx (8.5 KB)
NewFile.xlsx (9.9 KB)

Below here is the error I am receiving:

For more information on this project please refer to:

Once i imported and ran your workflow i am not getting this validation error. The first seq is running just fine.
Can you restart studio once and try?

Hi @nadim.warsi,

I am still receiving the same error. Please can you suggest any solution. It’s really important.

@reda @Wei_Zhang @badita @neonova

Hey @Tom1989
Could be isolated to that machine or user profile. You can try it on another machine or user and see if you still get an error. I am suspecting that an Activity is not installed correctly (reading the error message); make sure you have all those activities installed that it mentions (like Custom.Activities.VariableComparer.2.1.3 and Baidu.Activities.VariableComparer.1.0.4), or even try reinstalling them and restarting Studio.

If after testing on another machine or user and it works, then you could try copying the folders it mentions to your other user with the issue.

If all else, you could try reinstalling Studio fresh again.

Other than that, I’m unsure because I’m just reading what the error says.


Hi @ClaytonM, Thank you very much for your reply. Will try to see if these activities are correctly installed.

Also, can you help me on the property valuation case? I really need your advice on how to proceed further. I have shared all the details required for your perusal on that topic.


Let me check again @nadim.warsi.

It’s a type mismatch… sometimes It happens when some changes ar emade to the environment UIpath is running on. Try restarting studio else reinstall your studio.

@neonova @ClaytonM @nadim.warsi @loginerror @KarthikByggari

Hi All, I am still facing the same problem on the above. Please, can anybody enlist the steps to resolve it.

If I reinstall UiPath Studio, Will it affect all the projects I have saved as .xaml files? In the first place, will they be deleted when I uninstall studio?

I have also reinstalled the activities following @ClaytonM suggestion but the problem still persists.

Please advise.

Ideally on unistall it should not delete your .xaml files
however to be safe go to the diretory where all your .xamls files/projects are stored and take a backup

then proceed with unistallation and reinstallation (make sure you restart your machine before reinstalling)

@neonova, Can you tell me how to unistall studio? I could not find un-installation guide on the website or forum?

Use the default Add/Remove software in your Windows Control Panel



@nadim.warsi Here you go:


When im running your xaml it is working just fine. Not sure if you have made any changes to the one attached here in this thread.

Can you try the xaml you have attached here?


Dont know why, I am still receiving following error:

Source: Deserialize JSON

can you show your imports tab?

@nadim.warsi Here you go:


@nadim.warsi Please advise.

hey @Tom1989

Just Try to run this file and you have to change just your files path in excels and write range

Solution_Goodman_POC_New.xaml (65.6 KB)


1 Like

@aksh1yadav, In your workflow I encountered following error after donwloading -

Hey @Tom1989
it should not come or just reassign your variables :slight_smile:


@aksh1yadav, also one more error: