Upload Yearly Report Type into Activity for filepath is not working

Hello Robot Masters,

Type into activity for upload Yearly report is not working. I have tried all tips/suggestion from Forum. Still it#s not working. I have used Highlight activity to highlight Filepath UI Element. That is working. I have put delay before and after Type into. I am not getting any error.

Please help me find the error.
Thanks in advanced

@SVa - Try to enable “Simulate Type” in properties section.

Happy Learning :slightly_smiling_face:

I have enabled stimulate type. Still not working.
I have tested Type into activity alone. i am getting following error

Type Into File Path’: The target Element was not specified for this activity. You should set its Target property or use this activity inside of a scope activity (Attach Browser, Open Browser, Open Application, Attach Window, Get Active Window, Element Scope activities).

I have solved Target error, still type into is not working.

Is this a field that has a “Browse” button at the end? If so, this is a security feature of browsers. You can’t script typing into this type of field. If you could, someone could easily write a web page that steals files from your computer. In this case, your bot will have to click the Browse button then type the path and filename into the dialog box that appears.

If it is a regular (non Browse) text box, it’s usually better to use “Set Text” instead of “Type Into.” Try that.

@SVa - Try to use “Hot keys” instead of “Type into” activities.

Happy Learning :slightly_smiling_face:

Thanks Paul.
Set Text also giving error

Hello Jagadessen,

how to use hot keys for type text. win + r?
Can you please explain it. I am attching here workflow.
System1_UploadYearlyReport.xaml (20.1 KB)

Again, is this a text box with the Browse button at the end?

If so, you can’t fill in the field this way. You’ll have to have your automation click the Browse button and fill in the path in the window that opens.

This not text box with Browser button. In Ui Explorer it#s showing Combobox.

Ok that screenshot gives us more information. This is in the Chrome “open” dialog box not a text box on a web page. This is a special type of window. You should attach to that Window before trying to interact with it. And for the Dateiname box, use the aaname in the selector not the ctrlid. Also, from the error you may need to set “wait for ready” to complete. The automation might be trying to type into that box before it’s ready.

@SVa - Please refer the below screenshot.

Happy Learning :slightly_smiling_face:

Thanks for your suggestions.
aaname is not identifining the UI Element.
I have re write the workflow for the Upload yearly report process nad kept default property setting for Type Into activity. Now its working.

aaname is right there in the Ui Explorer. You can edit the properties it uses by checking and unchecking the boxes, or manually edit the selector. You don’t have to, and frequently shouldn’t, keep what Ui Explorer thinks is the right way to identify an element. It’s wrong more often than it’s right.