Upload Process with the same Package Name, link to the deleted Package


i have publish a Process with the Package Name ex. ‘Test01_Project’ with the version 1.0.1-alpha.4.

After view rework, i set a complete new Process Project. Before i delete the faulty one (first Folder Process, than Tenant Package). And upload this Project with the same Package Name, and with the Version to the Orchestrator Tenant 1.0.1-alpha.

If i run this Project it failed with follow error message.

It seams like, that the Orchestrator use the old (deletet) Process. How can i clean the Orchestrator from this Package Files.

Note: if i use a higher Package Version as i previus puplish or i rename the Package Name this works.


Info: Could not find file 'C:\Users\USER\.nuget\packages\test01_project\1.0.1-alpha.1\lib\net45\Flowchart_Main.xaml'.

RemoteException wrapping System.IO.FileNotFoundException: Could not find file 'C:\Users\USER\.nuget\packages\test01_project\1.0.1-alpha.1\lib\net45\Flowchart_Main.xaml'.
at Microsoft.Win32.SafeHandles.SafeFileHandle.CreateFile(String fullPath, FileMode mode, FileAccess access, FileShare share, FileOptions options)
at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String fullPath, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.Strategies.OSFileStreamStrategy..ctor(String path, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.File.OpenRead(String path)
at UiPath.Service.Job.OpenFileForUser(String path)
at UiPath.Service.Core.ExecutorService.OpenFile(Guid jobId, String fullPath)
at UiPath.CoreIpc.Server.<>c__DisplayClass7_3.<<-ctor>g__InvokeMethod|6>d.MoveNext()
--- End of stack trace from previous location ---
at UiPath.CoreIpc.Server.<>c__DisplayClass7_1.<<-ctor>g__HandleRequest|3>d.MoveNext()
--- End of stack trace from previous location ---
at UiPath.CoreIpc.Server.<>c__DisplayClass7_2.<<-ctor>b__5>d.MoveNext()
--- End of stack trace from previous location ---
at UiPath.CoreIpc.Helpers.Timeout[TResult](TimeSpan timeout, List`1 cancellationTokens, Func`2 func, String message, Func`2 exceptionHandler)


you need to check two conditions,
1st one:

First go to process and check if there is any process is using the old package, if so , delete the process or rollback the process to an older version, then update the new package in orchestrator and update the process also with new package

2nd one
Are you saving the package locally? if so then delete the previous nupkg file from the current file path and then retry

Waiting for your reply

Hi @muhamed_fasil

  1. i have already delete all old process, and than this package
  2. yes i store this package locally, after your feedback - i delete all *.nupkg from this process. and puplish a new version from the studio *alpha.1.nupkg

if i upload this new version, and update the process - i have the same issue.
the process stopped emiddily

Can u try creating a new process with new package in orchestrator and re run?


I’ve already done this, and that’s how I became aware of the problem. If I use a different package name, the first version also works


So the thing is the the old package is there in nuget folder in robot machine, to get to nuget folder go to c:/Users/%RobotUsername%/.Nuget/packages/“bot package name”/ there will be version of your package, delete that package and then install the original package once again

Hi @muhamed_fasil

you are absolutely right. These packages were still available on the VM, but I didn’t expect this.

Why are these not deleted on all robot machines via Orchestrator > Tenant > Packages > delete?

br Raiko

Through orchestrator the packages will be only been deleted from cloud, but since it is already installed in system with same version name, when u trigger the process , Assistant initially check if same version is available locally in system or not, if it is available it wont go for downloading from orchestrattor, So each time if you are installing a package with same version name u will have to remove the file from locally too

If the version is different the assistant automatically install the new version and run with that package

i made now a test with 2 different projects with the same Library Package.
The demo_project is a new Process, and this run without any issue. And if i create a project with a name (ex. test01_project – this previouse exist (i delete all local package project files on this VM) and this project failed.

I’m sure that the Library Project works without any issues. I compair the project.json from both projects, these are the same except unique id’s.

Note: the test01_project.1.0.1-alpha-dev1 never exist

Can you please show me the faulted error message ?


Demo_Library: Activity timeout exceeded

The Librar Demo_Library can handle follow Error Message (Delphi ERP Application)


in the demo project it confirms this message and returns the value ‘Allg. Fehler == true’
an application timeout occurs in the test01_project

Now i rename the Project Name from ‘test01_project’ to a other, and upload this new Project on the Orchestrator. And this failed as well :cold_face:

I have to look for the reason why it doesn’t work sporadically in a new project.

@raiko.m ,
Does your bot started execution?
Then that is not related to packages issue , it is bug in code


I do not think so, if i run the demo project (with the same package & properties and dependencies) it finish successful.

Only if i use this library package in a other new Project it failed :thinking:

When I run it locally attended (Debug File / Run File) this library package handle this error message successful as well. Only on the VM robot machine i have this issue.

@raiko.m ,
Can you copy the error message as text to this chat , as the language is different in picture i am not being able to understand!!
Can you click on the icon below and copy the text to the chat?

@raiko.m ,

The error seems to be an activity error , not a package installation error

the strange thing is, that this Library Package works in a other project without any issues.

I will start troubleshooting and hope to find the issue.

However, I suspected that when uploading the same project name, the older version would be loaded. But you were able to explain that to me. Upload Process with the same Package Name, link to the deleted Package - #9 by muhamed_fasil

Many thanks for your Support

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.