Upload PDF in Create Form Task

I am trying to add in a copy of the invoice (and a data table) to an action center form so that I can have the user validate the info (well past the validation action as the data has been modified at this point and put into a new table.)

I found a video to help me (How to Display PDF in Action Center - YouTube), and I followed all the steps by uploading the file to the Storage Bucket, and then using the embed function in the HTML element (adding height and width). When I run the program the action gives me one of 3 things- a spinning circle that looks like it is trying to load the file, BlobNotfound, or File has been moved, edited, or deleted, and none ever show the pdf, the latter being the most common. I even added a delay of 10 secs in between them and that is when it went from a BlobNotFound to File has been moved, edited, or deleted.

Here are images of the workflow (I cannot share the actual workflow.):


Embed wording for HTML element:
<embed src="{{data.pdf_storage}} width =“700px” height = “700px”>

Form Data input collection:

Appreciate any help that can be provided. Thanks!

Hi @potchak,

I followed the video and had the issue too, then realized the Refresh On Change checkbox. Please make sure that you checked the Refresh On Change property in the HTML element. It worked for me that way.

I used iframe instead of embed but I don’t think that will make difference.

<iframe src="{{data.pdf_storage}}" width=80% height=500px></iframe>

Cheers!

Thank you, not sure if it was the refresh on change or the fact that I was putting " around the width and height, but it does work now still with the embed. Appreciate the help!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.