Unnatended robot doesn't work

Hi guys, I’ve made a robot that it’s running smoothly, I’m keeping track of this remotely and when I’m logged on remote view it works but when I’m not it doesn’t work(PC still switched on), It seems to me that desktop area is locking or something but I already take out all passwords and did what I could to prevent it to go to login page, I’m activating it by trigger and gets “System Exception: Time limit at Source: Send Hotkey PageDown”. What can I do to solve this, it’s the only thing that I need to solve to complete this project.




On your Orchestrator, where you have defined created your robot.
Go to settings and Enable Login To Console and set it to true.

Hope this helps you.

Thanks, Lakshay, unfortunately I keep getting the same error.


It actually seems to open Browser and logs into the website I need but gives error on using hotkey

I hope you clicked activity property : Send windows message for send hot key ?

Please refer this as well


It solved! The process still gives error on other activities but I’ve just changed this hotkey activity, probably change it all from simulate click to send windows message will solve the whole problem, I didn’t think on it because it was not supposed to run with a locked desktop but anyway it is a solution and there’s no problem running it that way…


1 Like

Happy automation :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.