Unattended Bot not working

@ClaytonM @Dominic My Bot is not working in unattended mode. Its working fine on foreground. When I sechedule the bot through orchestrataor bot is not successfuly running. Throwing error with hot keys and some other parts. Not getting what is the exact issue. Please advise.

@sambana_karunakar can you please share the error message and what you are exactly trying to do ?

Hi.

This problem can be caused by a number of issues. So, you’ll need to do some troubleshooting like Taking screenshots when an exception occurs so you can see what the screen looks like in unattended mode.

Most typical solve for unattended issues is to run it in Interactive mode which can be set by calling your Main from the Launch Workflow Interactive activity or the newer Orchestrator versions have this setting for each Robot; just go to “Robots”, then Edit, then “Runtime” settings. You will want LoginToConsole false with the resolution that you use in your development machine which is most likely Width 1920 Height 1080 and 32 color depth.

If it is other issues not related to resolution, then there could be settings set up for the user profile being used as unattended, such as Pop Up blocker on that stops websites from working, various other browser settings, first time messages like for example first time opening Excel it asks for your name, or a different OS can cause some selectors to slightly different. The selector issue can be fixed by taking advantage of wildcards (like it is normally good to wildcard the app and extension in the title attribute of an Excel window since sometimes those are omitted in some environments.)

These issues are spotted right away if you are testing your process in the same user profile that you are running in unattended mode. So if that is the case, then the last fix would be to run it with resolution settings.

So, yeah, you can provide us with error messages, but it might not be that helpful because we need to actually see what the robot is doing while unattended, like what the screen looks like. And, you can usually determine yourself what might be the problem from those images as well.

Regards.

1 Like

Faced similar issue.
Tried the settings for the Robot via the Orchestrator, but didn’t work. So used the “Platform Installer” to install the “Java Bridge” for the “Robot” and “Remote Runtime”. This worked!
However not sure if this the right solution. Could anyone suggest?

What is Java Bride and Remote Runtime? I am having the same issue - build runs perfectly in studio but won’t work on an unattended robot - with screen open and also locked. I need to get it to the point where it is running behind a locked screen. Can you please advise.

Also is the only difference between an attended and an unattended robot that an unattended robot can log in to a machine? Can an attended robot EVER work behind a locked screen? (The process is web based and so has GUI interaction)

Thank you!

hello, I’m also facing similar issue -
The bot is supposed to launch win form and login and retrieve data; however it throws error ‘Hot Key not identified’, ‘Timeout reached’ - while entering user credentials
Even in Dev & Test environment, the bot runs fine in attended mode (from robot tray) however throws error while running in unattended mode.

Please suggest if any setting is missed