Unexpected Error during Orchestrator installation

Hi there,

i’m installing the latest Orchestrator (2020.10) by using the Platform installer. On the first node the installation went without problems, but on the secondary node i’m receiving the Unexpected Error.

I checked the prerequisites and all the previous posts in the forums on this topic - everything seem to be in order, but it is still not working.

Logs are inconclusive (from my perspective). Suggestions are very welcome.

Excerpt from the logs:
[1954:0E6C][2020-11-11T12:55:55]i301: Applying execute package: UiPathOrchestrator.msi, action: Install, path: C:\ProgramData\Package Cache{CAE4E935-5285-4A0D-9494-D144B74BB9D8}v20.10.2.0\UiPathOrchestrator.msi, arguments: ’ MSIFASTINSTALL=“7” NO_LICENSE_SCREEN=“1” ENABLE_UI_IN_SILENT=“1” ProductLanguage=“1033” PARAMETERS_FILE=“C:\Users\orchestrator\Documents\UiPathOrchestrator.msi_20201110184053_parameters.json” OUTPUT_PARAMETERS_FILE="" SECONDARY_NODE=“1” ADDLOCAL=“OrchestratorFeature,IdentityFeature”’
[1BE0:1878][2020-11-11T12:55:56]i000: ExecuteMsiMessage: Log = 1: 0 2: 1033 3: 1252
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = 1: 0 2: 1033 3: 1252
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Message type: 0, Argument: 1033
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Message type: 1, Argument: UiPath Orchestrator
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Action 12:55:58: INSTALL.
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Action 12:55:58: FindRelatedProducts. Searching for related applications
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Action 12:55:58: SetFirstInstall.
[1BE0:1878][2020-11-11T12:55:58]i000: ExecuteMsiMessage: Log = Action 12:55:58: LoadConfigParamsFromFile.
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: SetAppEncryptionKeyProvided.
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: AppSearch. Searching for installed applications
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: INSTALLED_ORCHESTRATORFOLDER, Signature: RegSearchInstallDir
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: TCPIPDOMAIN, Signature: tcpipDomain
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: URLREWRITE_INSTALLED, Signature: urlRewrite
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: PREVIOUSLY_INSTALLED_VERSION, Signature: RegSearchDisplayVersion
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: WEBSITE_NAME_OLD, Signature: RegSearchWebSiteName
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: APPPOOL_NAME_OLD, Signature: RegSearchAppPoolNameName
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: IS_APPPOOL_NAME_OLD, Signature: RegSearchIdentityAppPoolNameName
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: WH_APPPOOL_NAME_OLD, Signature: RegSearchWebhooksAppPoolNameName
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: WIXNETFX4RELEASEINSTALLED, Signature: NetFx4ReleaseInstalled
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: IISMAJORVERSION, Signature: IIsMajorVersionSearch
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Property: IISMINORVERSION, Signature: IIsMinorVersionSearch
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: SetHAS_SUPPORTED_IIS.
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: SetWIX_IS_NETFRAMEWORK_472_OR_LATER_INSTALLED.
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: LaunchConditions. Evaluating launch conditions
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: ValidateProductID.
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: CostInitialize. Computing space requirements
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: FileCost. Computing space requirements
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: CostFinalize. Computing space requirements
[1BE0:1878][2020-11-11T12:56:08]i000: ExecuteMsiMessage: Log = Action 12:56:08: CheckOrchestratorPrerequisitesQuiet.
[1BE0:1878][2020-11-11T12:56:12]i000: ExecuteMsiMessage: Log = Action 12:56:12: MigrateFeatureStates. Migrating feature states from related applications
[1BE0:1878][2020-11-11T12:56:12]i000: ExecuteMsiMessage: Log = Action 12:56:12: ValidateFeatures.
[1BE0:1878][2020-11-11T12:56:16]i000: ExecuteMsiMessage: Log = Action 12:56:16: ValidateEnvironment.
[1BE0:1878][2020-11-11T12:56:21]i000: ExecuteMsiMessage: Log = Action 12:56:21: ValidateAndSetProperties.
[1BE0:1878][2020-11-11T12:56:25]i000: ExecuteMsiMessage: Log = 1: 2 2: 0
[1BE0:1878][2020-11-11T12:56:25]i000: ExecuteMsiMessage: Log = 1: 2 2: 1
[1954:0E6C][2020-11-11T12:56:25]e000: Error 0x80070643: Failed to install MSI package.
[1954:0E6C][2020-11-11T12:56:25]e000: Error 0x80070643: Failed to execute MSI package.
[1BE0:1878][2020-11-11T12:56:25]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[1BE0:1878][2020-11-11T12:56:25]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[1BE0:1878][2020-11-11T12:56:25]i319: Applied execute package: UiPathOrchestrator.msi, result: 0x80070643, restart: None
[1BE0:1878][2020-11-11T12:56:25]e000: Error 0x80070643: Failed to execute MSI package.
[1BE0:1878][2020-11-11T12:56:25]i000: ExecutePackageBegin: UiPathOrchestrator.msi - should execute: False
[1954:0E6C][2020-11-11T12:56:25]i318: Skipped rollback of package: UiPathOrchestrator.msi, action: Uninstall, already: Absent
[1BE0:1878][2020-11-11T12:56:25]i000: Progress: Install progress: 62
[1BE0:1878][2020-11-11T12:56:25]i000: ExecutePackageComplete: UiPathOrchestrator.msi complete.
[1BE0:1878][2020-11-11T12:56:25]i319: Applied rollback package: UiPathOrchestrator.msi, result: 0x0, restart: None
[1954:0E6C][2020-11-11T12:56:25]i329: Removed package dependency provider: {CAE4E935-5285-4A0D-9494-D144B74BB9D8}, package: UiPathOrchestrator.msi
[1954:0E6C][2020-11-11T12:56:25]i351: Removing cached package: UiPathOrchestrator.msi, from path: C:\ProgramData\Package Cache{CAE4E935-5285-4A0D-9494-D144B74BB9D8}v20.10.2.0
[1BE0:1878][2020-11-11T12:56:25]i000: ExecuteComplete: Status: -2147023293
[1954:0E6C][2020-11-11T12:56:25]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{52e3d5e0-7d83-4e6f-b889-b807f9a2e26b}, resume: None, restart: None, disable resume: No
[1954:0E6C][2020-11-11T12:56:25]i330: Removed bundle dependency provider: {52e3d5e0-7d83-4e6f-b889-b807f9a2e26b}
[1954:0E6C][2020-11-11T12:56:25]i352: Removing cached bundle: {52e3d5e0-7d83-4e6f-b889-b807f9a2e26b}, from path: C:\ProgramData\Package Cache{52e3d5e0-7d83-4e6f-b889-b807f9a2e26b}
[1954:0E6C][2020-11-11T12:56:25]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall{52e3d5e0-7d83-4e6f-b889-b807f9a2e26b}, resume: None, restart initiated: No, disable resume: No
[1BE0:1878][2020-11-11T12:56:25]i000: ApplyComplete - Status: -2147023293; Result: None

Hello @elena.zk!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff