Unattended workflow?


I created and published a workflow.

And when I wanted to trigger it. I am not able to select the robot which work as the unattended.
The place to choose the robot is empty.

Does it means my workflow cannot run unattended??

I thought that all the workflow can run in attended or unattended mode.

And if the workflow is need to differentiate, how to check whether the specific workflow can/ cannot run in unattended?

Thank you

Hi @g_ii

Have you add the process in the processes?

Yes, the process is ald add in the processes.

Where did you publish the process Shared or personal workspace? @g_ii

Are you sure that machine template/robot is assigned to the folder you created the process in?

shared workspace

The image below is the situation where I am unable to select the robot

I added the process in the processes, and it also able to click at the trigger there. However, the below there didn’t show any robot that I can select.
PS: I have one robot which work for the unattended one.

And when I click at job there, the unattended robot did appear and is able to click.

Have you publish the process like this? @g_ii

In the studio bottom down do you have shared folder?


HI @g_ii

Check out the video link and document


I am able to click the name.
However, there is no robot shows when I wanted to trigger it to run daily.

And, when I use the option start job, the robot did shows at the bottom there

Hi @g_ii,

Are you using classic or Modern Folders?
If you are on classic folder, make sure the process and the unattended robot are in the same environment.

Kind regards,

Found that it’s not the problems with that.

It occurred because the orchestrator thinks that the workflow I build is not suitable for unattended.

But the way, how to make sure the process is unattended, and which activity should I avoid.

Hi @g_ii,

Check these settings:
2022-11-14 11_02_35-Desktop (W21-PAD221)

Maybe Attended Automatic is on yes?

Are you able to run other automations through a time trigger with this unattended robot?

Kind regards,


I am able to eun other automation through a time trigger with the unattended robot.

And currently suspect that maybe they have any activity make the orchestrator thinks that it’s a attended worfklow, not unattended workflow.

Currently suspect about few activity :
-click activity
-type into
-type security text
-click image
-send hotkey
All these activity, I didn’t enable the send window message or stimulate click option in the properties there.

Hi @g_ii,

Its worth a try, always try to simulate first, with browser automations its also possible to use Chromium API in the newer versions.

Kind regards,

The workflow is on a application.

And the stimulate click is unable to use as it shows generic error. Thus, currently, I am using send window message.

However, I now stuck at one part, it’s about select sub menu one.

Initially, the workflow send window message to click the menu. Then, send another window message to click the sub menu.
However, during the second activity, when the workflow send the window message, the menu is close.
It can click while I am not using the send window message (click by hardware).

Do you have any idea to solve this??

Hi @g_ii,

Can you show the selector in UiExplorer from the second click?

It looks like the first click isn’t executing aswell, could you show the selector from this activity aswell in UiExplorer?

What application are we talking about? Is it internal or is it an application I could test aswell? (Like Acrobat or Office)


The application is the company’s application, you are not able to test.

The first click actually function, as it did show the sub menu when it is click.
However, when the second click start, it send the specific message to the application, and when it send, the sub menu disappear.

I did try to test on the second click by using the mouse to click on the first click’s item while test on the second click, and it is successfully click the item.

Another test is when I disable second click’s send window message properties, it is also successful to click.
(However, the workflow I wanted to run in unattended bot, thus, I wanted it to run at background)

Thus, I suspect that when the workflow send the window message, the submenu’s visibility is change to none.

Hi @g_ii,

Do you have “Starts in background” set to yes in your project settings?

This can be the reason why you cannot run it, clicks etc are not suitable for background processes.
For more information: Background Process (uipath.com)

Kind regards,

No, the option is set to No.

But even though it is set to yes, the second click is also unable to click.

I think it’s because the menu 's visibility is too sensitive as it is close for every action.
For example, the submenu disappear when I click on the anything include any key on the keyboard.

Maybe can try to disable the send window message and the stimulate click of the second click. But scare that it will cause the orchestrator does not track the workflow as unattended.

OK, yes, you can use simulate for unattended processes.

I have a lot of unattended processes which use simulate on activities and its working great.

For more information: Input Methods (uipath.com)

For the visibility problem, you can try to use delayed restore while capturing in UiExplorer:

And if you want to check on the visibility of an element, you can use the get attribute activity and use it in a do while loop.

With the newer versions there is even a visibility check in the click activity under Target:
2022-11-15 09_41_58-Desktop (W21-PAD221)

Kind regards,