Bot is failing in Unattended mode but working from Assistant and Studio

Hi Experts,

I have automated windows application and it is working fine when i use to run it from Studio or Assistant.

When i disconnect VM and run it in unattended mode it is failing on a simple click activity. What i found is if i check Sendwindowmessage it worked fine.
But i want bot to work without SendWindow or Simulate, as few of the activities and hotkey is not working due this issue.

My VM resolution is 1280 x 720, when i am trying to make it 1280 x 1080 it is not even changing at runtime.

My VM resolution

Orchestrator Setting

Setting File

Looking for your help.

Hi @ermanoj3101,

Let us know the studio version also


Studio 2021.4.3
Orchestrator 2021.4.0

I never faced such issue before, let me know if you can help on this.

Hi @ermanoj3101,

Could you try adjusting the robot setting like so: Take screenshot fails in unattended mode when RDP disconnects - Help / Robot - UiPath Community Forum

In my view this is the issue due to Login To Console setting.


As @jeevith said, we can see that The Login to Console is disabled, but in the settings it is True

Let us know if this is working


Hi @jeevith ,

Thanks for the reply.

I have changed the settings but still facing same issue.

When i am printing width and height in logs it is showing 1280 x720

1 Like

Can you log into the robot machine with any admin user and check if you can change resolutions manually. Just to eliminate possible Resolution lock for all users in the VM.

I have also tried to set login to console value to false in settings file but getting same issue.

The problem is why it is taking default resolution when i am passing it from Orchestrator.

I don’t have permission to change resolution.

Please suggest some other approach.

I have opened Orchestrator in some other VM and triggering bot on other VM.
Is their any changes that bot is taking resolution of my current VM from where bot is triggered?

After you updated settings in Orchestrator, did you also try to restart UiPath.Host service.

Most VM providers do have features to lock guest/host resolutions on VM. You will have to contact the IT department to check if this particular VM also has a resolution lock.

This looks more like a user rights + VM resolution lock case.