Unable to use F2 to Pause recording & ESC key to end recording

Hi whenever I try to hit the F2 key on my keyboard I am unable to pause the recording and it doesn’t work. Furthermore I cannot end the recording by clicking on the ESC key. Any suggestions on how I can fix the issue? It is really inconvenient. I have a US English keyboard and a Dell 64 bit Windows 10 machine. Also I have UiPath version 2019.6.0 Community Edition.

1 Like

@ronsahota

Press Fn+F2 at a time and check once.

1 Like

@lakshman: I tried Fn+F2 on my keyboard and that did not pause the recording.

F2 and Esc keyboard should work buddy
Fine let’s do one thing
Let’s check whether it is a keyboard issue or uipath issue
— go to any folder in your system and click on a file and press F2 and check whether the file name is getting highlighted that is we could be able to change the file name
And if are able to change it then we are good with keyboard and so reinstall the uipath
Or
If it didn’t get highlighted then the issue is with the keyboard
So kindly check with that and as an alternative
Got start button and type keyboard and we will getting a on screen keyboard and try pressing that instead of of your keyboard in your computer and that should work if the keys in your system didn’t work

Try this buddy
This should work for sure
And you were almost done
Cheers @ronsahota

2 Likes

@Palaniyappan

I tried your feedback. When I press F2 on my keyboard I am able to change the file name. I reinstalled the community edition of UiPath version 2019.6.0 but that didn’t resolve the issue as I am unable to hit F2 key on keyboard to pause recording or hit ESC on keyboard to end the recording.

I also tried the on screen keyboard and tried to hit the ESC and F2 key but no luck got the same behavior on the on screen keyboard as I get on the normal keyboard.

I believe it is a UiPath issue but I cannot seem to install any other version other than 2019.6.0 since that is the free community version available on trial for free.

Any suggestions on how to resolve this issue would be greatly appreciated.

1 Like

Hi Ronsahota,

I’m just wondering which type of recording are you using? Is it Basic, Desktop, Web or Image?

See the general procedure is same in all recording types but knowing exact steps will help me to simulate the issue and help you better.

I tried both F2 and ESC worked fine for me.

The steps taken up by me are:

  1. Selected Recording -> Desktop. (Desktop Recording screen is shown)
  2. Click on “Record” button on screen.
  3. I press F2 or ESC the recording paused. Recording is paused for 3 seconds when F2 is pressed. But pressing ESC recording is paused and can be resumed only after clicking Record button again.
  4. Clicking on “Record” resumes recording
  5. Clicking on “Save & Exit” (or pressing ESC again) saves selected work flows and add those sequence.

Please let us know what happens when you follow above steps.

1 Like

@mrmanojrai

I am having this issue on Basic, Desktop and Web. The issue I have is on step #3. When I press F2 the recording doesn’t pause for me for 3 sec. Also when I press ESC recording isn’t paused.

Your description suggest that F2 and ESC keys are working in general but not with UiPath Recording mode. You have couple of other options to try:

  1. You can try F3 key if it work. F3 keys enables you to select a region while recording. Check if F3 is working on your setup.

  2. You can run UiPath Studio in administrator mode and then try. You have to right click on “UiPath Studio” in program list and select “Run as administrator”.

1 Like

@mrmanojrai

F2 and ESC keys are working in general.

I tried option #1 hitting the F3 key it didn’t work as it didn’t allow me to select a region while recording.

I tried option #2 by right clicking and running UiPath studio as an administrator and that didn’t seem to resolve the issue. Still unable to pause the recording by hitting F2 or cancel the recording by clicking on ESC key on keyboard.

If you like I can perhaps share my screen with you via Skype or Gchat and you can see my issue live. Hope that can help resolve the issue. Let me know if that works for you.

Thanks once again.

1 Like

@ronsahota

I guess Keyboardmapping.xml file missing in your installation file.

Please check below thread and follow the steps. Hope it’s resolves your query.

1 Like

@lakshman

I did a search on my file system and got no results back for keyboardmappings.xml file. I downloaded the keyboardmappings.xml file into my

\AppData\Roaming\UiPath

folder and ran UiPath studio as an administrator but was still unable to pause the recording by clicking on F2 key or end the recording by hitting the ESC key.

Anything I am doing wrong?

1 Like

@ronsahota

First search under this folder: %appdata%\UiPath\UiPath\keyboardmappings.xml

If is not found then place it under the above folder. You can download this file from above thread.

@lakshman
I did a search on my file system and got no results back for keyboardmappings.xml file. I downloaded the keyboardmappings.xml file into my

\AppData\Roaming\UiPath\keyboardmappings.xml

folder and ran UiPath studio as an administrator but was still unable to pause the recording by clicking on F2 key or end the recording by hitting the ESC key.

Anything I am doing wrong?

2 Likes

@ronsahota

Under UIpath folder one more UIpath subfolder is there and place it there.

If still it not works then uninstall and delete appData folder and reinstall it again.

1 Like

@loginerror @Pablito

I checked this issue and we are not able to identify what the exact issue. Could you please help him.

We tried all ways like placing keyboardmappings.xaml file, Running UIPath studio as Administrator, uninstall and reinstall studio and disabling Anti virus but no luck :frowning:

2 Likes

Hi @ronsahota,
I had once similar problem with other application. The problem was caused by other application (running in background) which took over some keys and shortcuts functionality. Please try to switch off everything you can on computer by going to Task Manager and close applications from User tab.

If this as well as re-installation is not helping then please also try to update .Net to newest version and check out if switching Studio to Beta channel will solve your problem.

3 Likes

@Pablito

We tried to update to Beta channel also but still no luck.

2 Likes

I have an idea. Maybe it’s worth to try if on screen keyboard will have the same problem :slight_smile:

2 Likes

@Pablito

That also we tried :slightly_frowning_face::slightly_frowning_face:

1 Like

Oh sorry, I missed that part. So let’s try with closing all unnecessary applications.

1 Like