Unable to select save as button in notepad

unable to select save as button in notepad as indicated target
i press f3 for the drop to appear
once the dropdown menu appears and i select save as button
it will open another window to save the file

i’m doing below lesson.
https://academy.uipath.com/learningpath-viewer/1962/1/153863/11

Hi Benjamin, I’m assuming you are doing the Create a Strong Password practice.

If you want to save the Notepad file, there are a few extra steps you need to perform:

  1. A Click action to click on File
  2. Another Click action to click on Save as. After you click on “Indicate target” for this Click action, you need to press F2, to pause the selection, click on File again and wait for the selection to be active and indicate Save As.
  3. A Type Into action, to name the file. At this point, you have 2 options: either pause the selection with F2 and perform the 2 clicks above to open the Save As window, or outside StudioX, in Notepad, open the Save As window.
  4. Another Click action to click on the Save button.

It’s important to think of all the actions you perform when you interact with the applications because a robot will mimic them.

Hi, i am having the same problems, when i try to “save as” using the notepad, even if i follow all the steps above, after the F2 when the selection is active when i click on the button it opens a new window, like if i was really trying to save the file instead of just indicating the target

you put into words better than me …

kindly sad for me that the first lesssons having problems already .

how about u ?

Hey, i redownloaded de studioX, before my version was 2020, and i had those problems, because i clicked to download the version with more updates in the website, but when i download de 2019 version, choosing the stable option (less updates) it worked fine, i’m being able to save notepads now
Maybe it works with you too!

thanks leo

installling the 2019 version as you kindly suggested worked for me …

finally able to build my 1st robot …woo hoo …

onward and beyond …

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.