Not able to select "save as" button in Notepad

When I am trying to identify and select the “Save as” button in notepad for click automation, the button is not getting selected. Instead, it is getting clicked and the next screen is getting displayed. My step by step flow is as follows:

  1. Using click activity select the “File” button on the ribbon.
  2. Using the click activity and by pausing the identification by 5 seconds(Using F2), trying to select the “Save as” button. But as soon as I click on save as button in order to select it, it is actually getting clicked and control is moving to the next screen.

@Surya_Chandra_Lagisetti Try to use Attach window activity for click activity.

@Surya_Chandra_Lagisetti Try to use send hotkey activity and next, select the folder where you want to save. Go through this you will sort out your problem
Example.xaml (9.7 KB)

1 Like

The code is very detailed. Thank you very much for the effort. The problem which I mentioned above is in Studio X and in there I’ve been trying to use the click activity. Unfortunately, we don’t have “Do”, “Send hot keys” activities in Studio X.

Hello @Manjuts90 ,

I don’t see any activity named “Attach Window” in Studio X.

@Surya_Chandra_Lagisetti can share screenshot of your code, i tried in studio x it working fine for me but didn’t get any issues while running the code…

Hii @Surya_Chandra_Lagisetti

Use Recording -------> Desktop and record it

Use this

see the example same as your requirement


@vamsiyeluri, Kindly check out this link. Thank you.

@gulshiyaa, this method is very interesting and useful for my future works. Thanks for this topic. However, in my case, my issue is I am not able to select the “Save as” field which is inside the “File” from menu options. I have attached a video in reply to @vamsiyeluri’s comment, kindly check it once for clear understanding. This is the link for your reference.

Here is the screen recording for your reference. You can notice how “Save as” button is getting clicked instead of getting identified.

Hi @Surya_Chandra_Lagisetti

Ok Then use keyboard shortcuts activity


Its working for me I Hope its work for You too


@gulshiyaa, Thank you very much. It works.

Yours most welcome @Surya_Chandra_Lagisetti

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.