Unable to run Python Scope: Error initializing Python engine 64 bit

Hello All,

I am unable to run python scope with Uipath.Python.Activities 1.6.0 for python 310 x64 version
any clue on what am I missing here?

Python is installed in location : “C:\Users…\AppData\Local\Programs\Python\Python310”
the same path is also available in environment variables PATH

When I run the python from my VS code it works and I get a response.

Is there any environment that I need to adjust for uipath to load python properly? or am I missing on the parameters to be used correctly?

Did quite a search in the forums but could not get a solution that works

thanks,
Kiran

1 Like

Hi @kduvvuri

Have a look on the thread

Regards
Gokul

@kduvvuri

Can you set the version of the Python instead of Auto?

Thanks

Hi @kduvvuri,

Your use of parameters looks good. I cannot confirm the Path from your screenshot, but I am assuming it is as you write in your post :

I recently was playing around Virtual Environments and I did get the same error as you (Error initializing Python engine). My best guess is the way Python 310 has implemented its folder structure, UiPath fails to parse it and find the python.exe file. I am guessing here as I don’t have Python310 installed to confirm this. In a virtual environment this is the case.

If you have other version of python installed it is worth a check.

The thread I am refereeing to :

I did that still an issue :frowning:

I got help from uipath support and this issue got resolved after having the python dll path updated in the library path as shown below

5 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.