Unable to run nupkg file

Hi,
I created a batch file and in that i asked uirobot.exe to run my nupkg file. when i run the batch file, it says ‘unable to connect to orchestrator’. i didnt install that and i dont need it. how to fix this?

“C:\Users\X\AppData\Local\Programs\UiPath\Studio\UiRobot.exe” -file “D:\UiPath\WorkspaceRPA\WorkspaceRPA\WorkspaceRPA.1.0.3.nupkg”

Hi @zeesh19791

UiPath orchestrator is not a application it was the webpage you can find this on Cloud.UiPath.com link.
The UiPath bot will run in the studio with orchestrator connection only. With out connecting to Orchestrator we can’t.

First connect your studio with UiPath orchestrator, then run the program from Studio.

Hope it helps!!

@zeesh19791
did you install UiPath Assistant? if yes please connect with orchestartor and try to run your batch file.

i already have assistant but no orchestrator. on my other system, the bot runs perfect. there is no difference in the installation of both systems.
i only installed UiPath studio and assistsant, generated nupkg file and running it via robot

@zeesh19791
If you don’t have Orchestrator installed and you don’t need it for your automation process, you can modify your batch file to run the nupkg file without attempting to connect to Orchestrator. You can do this by adding the -noorchestrator argument to the UiRobot.exe command.

Here’s an updated version of your batch file:

"C:\Users\X\AppData\Local\Programs\UiPath\Studio\UiRobot.exe" -file "D:\UiPath\WorkspaceRPA\WorkspaceRPA\WorkspaceRPA.1.0.3.nupkg" -noorchestrator

By adding the -noorchestrator argument, the UiRobot.exe command will execute the nupkg file without attempting to connect to Orchestrator.


i get attached error, saying noorchestrator is unknown

@zeesh19791 show me how did you put?

@zeesh19791
Can you try this “UiPath.Executor.exe” instead of “UiRobot.exe”:

"C:\Users\X\AppData\Local\Programs\UiPath\Studio\UiPath.Executor.exe" -file "D:\UiPath\WorkspaceRPA\WorkspaceRPA\WorkspaceRPA.1.0.3.nupkg"

@zeesh19791 Try above one with executor

i tried with executor. the batch file ran but it did nothing

Hi @zeesh19791 and @raja.arslankhan

What you are trying to do was possible some releases ago, but not anymore if you are trying this on community edition

“Air-gapped” runs of robots are no longer possible using the UiRobot.exe from cmd. You need to be connected to the orchestrator to run any local nuget packages as well.

That said, if your robot is connected to the cloud orchestrator and licensed, you can run your automation. Remember to also include arguments in json format, if your entry point uses any arguments.

The posts which discusses this:

-----------------------------------------------------------------------------------

@raja.arslankhan your earlier reply from ChatGPT is incorrect.

LLM’s are know to hallucinate. This is clear when it provides an argument -noorchestrator, to UiRobot.exe, which does not exist.

Please cite that you have used a response from LLM when you use them, it is important that the user asking the question knows the references.

1 Like

what i noticed is that my UiPath assistant has to be in online status to capture the automation. i connected my computer to internet, assistant got online. after i disconnected the internet, the automation ran fine. so the work around would be to connect internet before running assistant. when it gets online, i can disconnect and let the robot manage the automations which dont need connectivity

@jeevith Thanks to correct me.