UiRobot is connected to Orchestrator, how can i run project locally


My UiPath Robot is connected to Orchestrator.

I have publich a project with option “custom” and i have .nupkg file in Packages folder. But I can not see that project in UiRobot.

For security reason the setting is also locked… what to do?
Can someone help.

@Latif - in orchestrator → upload your package and create a process… once you create the process → the process will appear in the uipath robot.

1 Like

I have no access to orchestrator…
The orchestrator is setup by another department… and I am not from that department who have access…
Our department is just creating RDA Projects so queston is … how can i run my project from UiRobot even my uirobot is connected to orchestrator ?

You can manually add the nupkg file to the robot processes locally by adding it to the following folder:


Once it is there it should show up in your Robot Processes. If you want to do this as a preference, then set this folder to the default publishing folder when not publishing to Orchestrator (see screenshot below)

**Note, sometimes the location of this folder changes over different UiPath versions, so this may go out of date over time. However I can see you are using a version around the 2019.10 release, which this workaround should work for

Edit - if you think you do not have a ‘ProgramData’ folder it is probably just hidden, as it is by default, but is still there :wink: you can un-hide it to view in the ‘View’ ribbon of Folder Explorer:

1 Like

My file is there…
But UIRobot tray is not showing that package… :frowning:
My studio version is 19.10.2.

OK, you may need to check it is taking from that feed. there is a UiPath settings file located in:

C:\Users[YOUR USER ID]\AppData\Local\UiPath

and in there should be a file called:


If you right click and open that file using the Notepad application, you should see its contents, including the feed address, if it not already set to the packaged address we gave earlier, change it and save it and try again:

**Worth noting that this will more than likely sever the connection to the Orchestrator package feed, so you may want to consider asking the people who have control of Orchestrator to just create you a process

thanks for the help… but my folder have no UiPath.settings file and have only those files.

It may be worth doing some searching to find that uipath.settings file, as i say these files can move from version to version

the one is located under …
hope its that you means by?

Thanks for the help but look like i need to contact the Orchestrator team and I have no rights to open that file either.


Yes, that should be the correct folder, but it doesn’t seem like you are an admin which means you can’t change it.

If you believe you are in fact an Admin on that machine and so should not be getting this permissions error, try going into the security properties of that file and actually adding your user specifically as having full modify access. I know it sounds strange as you are giving yourself the permission, but this will work if you do actually have admin rights on the machine