UiPath Robot: Start/Run .nupkg via comand line

I do not want to use Orchestrator. I want to use UiPathRobotI am trying to start/run published package .nupkg file
via command line I am able to run xaml file but receive error when I pass path of NUPKG file (as explained https://www.uipath.com/kb-articles/start-process-from-command-line)
OR
via rest command: (as explained https://www.uipath.com/kb-articles/uipath-robot-api)
I am able to run xaml file but receive error when I pass path of NUPKG file

Error: for example when I run command
“C:\Program Files (x86)\UiPath Platform\UiRobot.exe” /file “C:\ProgramData\UiPath\Packages\Samples.1.0.6634.39428.nupkg”
I get following error:
image

on the same time when I try to run xaml file It run successfully. for example
“C:\Program Files (x86)\UiPath Platform\UiRobot.exe” /file “D:\Samples.1.0.6634.39428.xaml”

Can anyone explain how to run nupkg file via command line or Robot Service API?

Hello @adil.khurshed,

Please , go through these links:

Run process form command line:

Run proccess via rest command:


Regards,
Susana

1 Like

Thanks @Susana for your reply.
First of all I do not want to use Orchestrator. I wan to use Robot API.
XAML is working for me with Command line as well as Robot API.

Issue is with running NUPKG files, please see the issue detail and screenshot and suggest how to run NUPKG files using Robot Service NOT Orchestrator. Thanks in advance.

Hello @adil.khurshed,

if you do not want to use Orchestrator then you can not use rest command:

image

For running an automation project firstly you need to decompress it

Take a look,

image

Regards,
Susana

2 Likes

hello sir, I am very exited to know how to start and run an xaml file using command prompt. i have tried to do it but endedup getting errors. can you please help me out with this, please.

Hi I just wanted to download and run a “. NUPKG” file in a uipath community edition. But I am unable to do so. I can do it all with codes in WinRAR format where I just had to extract and run .Kindly help me!! Please!!!

Hey DOUBLE CLICK on the and select “uipath” TO RUN.

Thanks for the reply,
but this wont work.
I have tried this long back but it just opens the xaml file in uipath,It Won’t execute it. Anyway thanks for the reply. i found another solution to achieve the same.

Move the folder of the project (that contain the versions of the robot) on Desktop. You should run them now, by using “C…\Uirobot.exe” -file “C…\Main.xaml”.
Not a permanent solution, but it should do your work.

If you want to run the nupkg from the publishing folder with UiRobot it won’t work.