A local license is required pop-up

Hello guys,

So currently I have a problem when I run my robot on UiPath Assistant using a nupkg file (Offline without connecting to Orchestrator). This error pop up.

I already try the solution on this forum but still not finding a right solution (I’m using UiPath Community Edition). I already try to uninstall the UiPath, it work for like 2 days and then after that it pop up again.

Can anybody have the solution for this?

Hello @Yogi_Gozali

Have you configured the license properly? If not please check the below video.


Unfortunately, the latest Studio CE cannot work offline as the following post.

This means it works until the expiration date of the previous offline activation, but after that it requires a connection to the OC. So, there is no way but connect to OC with Community Edition or purchase Enterprise license to run offline.


Hi @Yogi_Gozali,

Sadly this has been enforced on all levels both Community and Enterprise version. We have tested this on our instances.

Airgapped automations will no longer work if the UiRobot.exe is not connected to Orchestrator.
Using Task Scheduler or invoking UiRobot.exe from other programming languages, will also not work if the host robot machine is not connected to the Orchestrator.

UiPath has done this to ensure that robots are linked to licenses. I am sure they found out that many used the airgapped hosts to run automations and used task manager. This meant that UiPath is losing revenue on Orchestrator Licenses. An additional reason is what is mentioned in the link above.

I personally, was disappointed that this was done. But as UiPath is a public company, I understand UiPath predicament, tap on to all possible revenue streams.