Unable to Read Excel

I’m unable to read the excel when my Bot is getting executed from orchestrator. The code works perfectly fine on my machine and can read the excel without any issues. I get the below Error message when the Code is executed from Orchestrator :

Method not found: ‘Void UiPath.Excel.WorkbookApplication…ctor(System.String, System.String, Boolean, Boolean, Boolean, System.String, Boolean)’

I have already tried the below steps:
1. Making sure the bot has the access to the required folder, and yes it does.
2. Roll back Excel activities version on my machine and make it similar to the one installed on orchestrator.

But I’m still getting the same issue. Some guidance will be really appreciated.

Thanks Rishi

If you have checked the property visible in your excel try to uncheck this and run from orchestrator.

Thanks for the reply @Divyashreem, I solved the issue. Apparently orchestrator tends to download and use the activity packages as mentioned in the project.jason . If the version is less than the one already downloaded and kept in orchestrator activity directory it won’t download the new package.

The new package in orchestrator directory wasn’t compatible with the older version mentioned in the project.jason .

I rollbacked my version of activity to last successful ran version and copy pasted the same package in orchestrator directory’s activities folder ,and it worked :smiley:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.