Unable to publish process into Orchestrator

Hi,
I am using UiPath Studio Community Edition.
I made a simple process where it only contain message box with “Hello World” text. It can be executed successfully but failed when I tried to publish / validate it.
Following is the error message:
Cannot execute a program. The command being executed was “C:\Windows\Microsoft.NET\Framework\v4.0.30319\vbc.exe” /noconfig @"C:…
Steps that I have tried:

  1. disconnect the robot from orchestrator and reconnect it.
  2. delete json file and launch my process by clicking Main.xaml.
    Did I miss any step? Can someone help me?
    Regards,
    Maya
1 Like

Hi @MyNovel

welcome to uipath community
Kindly Make sure these steps were followed
–your machine is connected with orchestrator
–your robot domain and username is same as in your machine and to find that in command prompt type as whoami which would give us the domain and username and that is what is to be typed while creating robot
–once after creating robot with the machine we have created, make sure that robot is provisioned to a environment, so create a environment in orchestrator and tag that robot to that environment
–then in your machine connect to the orchestrator
–once after connecting to orchestrator, in our studio publish the process we have designed
–we will be getting a package version
–now coming back to orchestrator in process tab create a process with that package version and choose the environment where we want to execute the process
–and once after assigning that process to a environment now run the job with JOB tab in the orchestrator and choose the process and its environment
–then choose the robot with which we want to execute the process and click start,

hope this would help you
kindly try this and let know for any queries or clarification
Cheers @MyNovel

After trying the steps mentioned above by Palaniyappan,
You can also try:

  1. Check if the .NetFramework is installed properly and pointing to the right version installed in your machine. Check this in registry.
  2. Restart robot service from task manager and restart UiPath.

Hi @Palaniyappan,
I have done and recheck steps 1-4, however step 5 ("–once after connecting to orchestrator, in our studio publish the process we have designed") give me the error message I mentioned earlier.
regards,
Maya

can i have a screenshot of the error we get if possible
Cheers @MyNovel

uipath-error.pdf (421.6 KB)

Do you need the log, @Palaniyappan?
Btw, last month, I managed to publish 3 processes, but today when I tried to publish I encountered this issue even with simple process.

no buddy
can i have just the screenshot of the error that appears when you are trying to publish
Cheers @MyNovel

it is inside uipath-error.pdf - 3rd image

Hi @rachrahul2,
For step 1, can you please elaborate more on this? kindly let me know the path to find the correct .NetFramework in registry that you mentioned earlier?
For step 2, I have tried this and still doesn’t work.
regards,
Maya

uipath-error2.pdf (310.7 KB)
Hi @Palaniyappan, this file contains the screenshot of error that appears when I am trying to publish / validate (same error message).

Hmmm…
i guess its something related to dot net framework issue
kindly install latest version of dot net framework and try once after restarting the machine
Cheers @MyNovel

Here is a link to check:

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed
and

Hi @Rachrahul2,
Thank you for the link. The release value is 461814 (.NET Framework 4.7.2).

Hi @Palaniyappan,
OK, I will try to install 4.8.

I will update later. Thank you

Hi @Palaniyappan and @rachrahul2,
I have installed the latest .NETFramework (4.8) and now I can publish again. Thank you very much for your help.
regards,
Maya

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.