Unable to publish a workflow in UIPathStudio


I am unable to publish a workflow in Orchestrator. Getting an error message "A robot with username ‘xyz’ is not defined in Orchestrator’. I have given the same name which i got from the ‘whoami’ command. Can you please help.

I have tried out this methods but it didnt work for me:
methods which i have tried


Could you please show me the screenshot of Robot system tray and also Machines page in Orchestrator once.


Thanks for responding
I have noticed one thing. The machine key is different in system tray and the machine in Orchestrator. But im copy pasting the same thing and as soon as it gets connected it is getting changed. Any idea why it is happening?


I created another machine and connected it. This time i have the same machine key in Orchestrator as well as system tray, but im getting the same error .


Could you please send me screenshot of Robots page in Orchestrator and in that you have to Specify DomainName\Username of the machine the one you wanted to connect.

To check this open CMD prompt and then type whoami. This command will give you exact domain name and username.

Hi Buddy @Farheen_sultana

Welcome to uipath community
you were almost done buddy
the machine keys are correct and they match with each other
the machine names are still different buddy and they should be same as well
see in either of the machines

–kindly make them same and make sure that robot is tagges to a environment as well
And for that in robot tab create a environment in the environment tab and add that robot to the environment
–once its done disconnect the machine in robot tray check with key and machine name both are same in your machine and in orchestrator and in robot tab as well
Now connect and try buddy
That should work for sure
Cheers @Farheen_sultana

@lakshman and @Palaniyappan Thank you so much it worked. :slight_smile:


Cheers @Farheen_sultana