Adding a worflow created in Studio to Orchestrator

Hi, I have created several workflows using UiPath Studio. I have installed Orchestrator and want to use UiPath robot to run my process. How do I do this using Orchestrator? My UiPath robot currently says robot unavailable.


Connect your robot with orchestrator and refer the below link about how to connect robot to orchestrator.

  1. Create machine in orchestrator after creating it you will get machine key copy it.
  2. Open the uipath robot tray settings and provide url as and machine key as the above key and connect.
  3. Create a new environment.
  4. Create a Robot, while creating a Robot, you have to select which type of robot select Development as CE comes with 2 Free Development licenses.
  5. Publish the package to orchestrator.
  6. Create a process for that package, where you have to provide, package name, version and environment.
  7. Trigger the job, here you have to provide on which process and which robot you want to trigger the job.

Don’t forget to start the robot service from services.msc


Hi, when publishing the robot to orchestrator I’m getting an error.

‘Error: Publish of workflow project to Orchestrator failed. A robot with the user name SCIS\IT15MCE is not defined in orchestrator.’

When I created the robot the mentioned username is the one I used?


Can you share screenshots of your robot configuration and the error message.

Also since receiving this error my process will not execute

Hi @rparookie97

I think the domain\username might be case sensitive, could you check?


In your local machine, go to cmd and type “whoami” and you will get the username, copy the username and provide in robots username.

Hi @loginerror, I tried it as capital and lowercase and still didn’t work

Hi @anil5, I have tried that and still getting the same issue

Could you go to the Tray Agent and paste here the status message? Is it Robot Unavailable?
If so, please hover over the text “robot unavailable” and type here the error from the pop-up that will be displayed.

@loginerror the error is robot unavailable and the pop up says the machine key is linked to another machine

I think you can go to the MACHINES tab and copy the Machine key of the machine that is called RPA-Student-Dashboard:

Use that key to provision your robot.

I believe you are using a Machine key of another machine.

You can also post a screenshot for the Machines tab for more reference :slight_smile: However, I am 100% sure that if you search this Forum for your error message from the pop-up, you will find your solution :slight_smile:

Hi @loginerror, that’s where I copied the machine key from in the first instance :frowning: but I will search the forum more, thank you!


Could you provide the screenshot of the orchestrator settings in the robot tray.

@rparookie97, can you please confirm if the machine key is same in orchestrator and robot tray.

Please help with the robot settings.

Can you give a try with the URL, in the robot tray

I have changed URL to, I only have one machine in my orchestrator and I copy the machine key directly from there and I only have one robot also


Why you have 2 different machine names in orchestrator and in Robot Tray (EMMA-PC) and (RPA-Student Dashboard).

Can you also check if the machine key in orchestrator and in robot tray is also same.


It worked! Thank you so much @anil5, I don’t know why I had the machine in orhestrator named differently