Unable to proceed further training in Academy2

academy2

#1

Scenario: I have started the Academy 2 training, I need to submit the Assignment 1(ACME hashkey generation). We have to use same mail id for the academy and ACME site, I have used the same mail ID for both Academy and ACME system site. I am getting error as attached in the screen shot.

Steps to reproduce:

Current Behavior:

Expected Behavior: Submitted assignment should be considered for the Evaluation, since I have used same mail ID to login Uipath Academy and ACME systems.

Studio/Robot/Orchestrator Version:

Last stable behavior:
Last stable version:
OS Version:
Others if Relevant: (workflow, logs, .net version, service pack, etc):


Advanced Training(Academy 2) - Assignment scoring feedback
#2

Hi Girish,

You may find your answer here:


#3

Hi @ovi,

Thank you.
We have to design the assignment according to RE framework.
I think we have to go back to the academy video again and download the PDD and design as per the RE framework.
I have to have submitted the workflow since I am getting error as I explained previously.
Here we should go to file UiPath ReFrameWork or https://github.com/UiPath/ReFrameWork and download the ZIP file to proceed with assignment…

Thanks
Girish


#4

You don’t have to use the REFramework, it’s not mandatory. If you have your own solution and it works(items are correctly processed in ACME) you can submit that one. The framework is for guidance and to give a better view on best practices in developing a real process.


Generate Yearly Report
#5

Hi @ovi

Already submitted workflow without RE framework, that is working fine.


#6

Hi @ovi,

I have uploaded the right solutions 5 times still getting the same error.
Please anybody’s help will be appreciated.

Thanks
Girish


#7

Hi Girish,

So, you have score 0 every time? I noticed that this happens when there are no data in ACME(when reset test data before receiving the evaluation score). Please let me check and get back to you. Do you use the same email address as this one on forum?


#8

Hi @ovi

Yes everytime:slight_smile: .
There is a data available before I ran.
Yes I am using the same mail address for ACME and Uipath academy

Thanks
Girish


#9

Hi @ovi,

Solution is working fine but still getting the error as shown below:

Please help me on this.

Thanks
Girish


Generate Yearly Report
Client Hash Evaluation
#10

Hi again,

Could you please check your text in SHA1 generator? Maybe it’s the same problem as in the post below and that’s why it’s showing 0 correct items:


#11

Hash code formula mislead from PDD … this solved my problem i was stuck for more than a week


#12

Hi @ovi,

I have completed my assignment 2, but score showing 0/100. It’s working fine in my system and I haven’t reset the test data. Can you please check and let me know what is the issue?

Thanks
Avinash


#13

In which format are you supposed to upload your result. My process works fine, but it seems like I need to process all items, and then I can upload a random file, and I will get a 100/100.
But if I just upload my process, I will get 0/100.
Don’t think that is how it should work.


#14

Hi @ovi,

Can you please give it a check on Academy 2 Assignment 1 evaluation error


#15

Why is my training now locked


#16

Hi Ovi,

Solution is working as expected but still getting error in result, please find attached screenshot.
Do I need to remove space between first name and last name of client name?


#17

@Amol4291,

I have noticed most of the people who are trying for advance certification is doing this -
removing all the spaces while creating the hash code.
I dont think this is mentioned anywhere to remove the spaces in PDD
Please follow the PDD and no extra logic is required.

Example :
in_ClientID &"-"& in_ClientName &"-"& in_ClientCountry

We can use trim as there could be spaces in the starting and end of the strings as you may be using split or any logic to find the required data. Which has the probability of having extra spaces in the starting and end.


#18

@priyanka.yadav18

I developed solution by following PDD only and it is working as expected. I am using trim function for removing white spaces.

After uploading 2 times still getting error in result. Still not able to figure out the reason. Any help highly appreciated.

My question was say in_ClientName variable contains value James Bond, do I need to provide in_ClientName value as JamesBond? Currently I am keeping it as it is say A701927-James Bond-India


#19

A701927-James Bond-India this is perfectly fine.


#20

Cool…what could be the reason for getting result 0/100? Spend lot of time scratching head.