Unable to Connect BOT with Orchestrator

orchestrator

#1

Have updated the certificate and created new ROBOT in Orchestrator. But When I try to connect UIPath robot with orchestrator , throwing ‘Bad Request’ error.

Can you help to resolve this.

Orchestrator


Bad Request
#2

Hi @kjana83

This error might occur because the request sent to the server was incorrect or corrupted and the server couldn’t understand it.
Please go to Event Viewer -> Windows Logs -> Applications and check if there is any log with UiPath Source(in order to see more details of the error).


#3

also try to open orchestrator from the robot machine


#4

Hi, i’m also getting similar issue as kjana83.

Below are the logs in the event viewer:

{“message”:“UiPath.Service.Orchestrator.Clients.OrchestratorHttpException: Bad Request\r\n at UiPath.Service.Orchestrator.Clients.OrchestratorClientExtensions.OrchestratorEnsureStatusCode(HttpResponseMessage request)\r\n at UiPath.Service.Orchestrator.Clients.OrchestratorClient.d__13.MoveNext()\r\n— End of stack trace from previous location where exception was thrown —\r\n at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at UiPath.Service.Orchestrator.OrchestratorController.d__23.MoveNext()\r\n— End of stack trace from previous location where exception was thrown —\r\n at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()\r\n at UiPath.Service.Orchestrator.OrchestratorController.d__23.MoveNext()\r\n— End of stack trace from previous location where exception was thrown —\r\n at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)\r\n at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)\r\n at UiPath.Service.Orchestrator.OrchestratorController.d__22.MoveNext()”,“level”:“Error”,“timeStamp”:“2018-03-13T01:03:24.4773152+10:00”}


#5

Opening the Orchestrator link inside the Robot’s machine, I’m getting the following error:

Network Error (tcp_error)

A communication error occurred: “Connection refused”
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.

For assistance, contact your network support team.


#6

Hi @ovi

i have created the my new robot after that how can i able to make the Status As “Available”
Can you please help me !!

Regards
RaviDevaraj


#7

Please find the solution in the below link .