Unable to click with IE 'Save As' dialog in unattended bot

Hi guys, can anyone guide me on how to click IE ‘Save as’ with an unattended bot? It seems that my robot could not click ‘Save As’ while running in the background.


1 Like

hi @sam.lee

go through the below loop

It doesn’t work, my robot just stuck at clicking “Save As”

Can I see screenshots or can you attach the workflow? I think I’ve encountered something like this before.

Hi @caduque, sorry I can’t share the workflow here but I can share you the screenshot.

I tried stimulate click/send hot key or whatever info I got from UiForum, but it doesn’t work. :tired_face:

Try keeping “Save As” click in parallel sequence.

Yeah we had the same problem before. Try following these steps:

  1. Use Attach browser
  2. Inside Do statement, use Activate activity and click the pop up
  3. Add a delay like 2 seconds
  4. Use Click activity for Save drop down
  5. Use Click activity for Save as
1 Like

Hi @caduque, can you elaborate more on the Activate activity? I never use this activity before

1 Like

Fine use activate activity and then use CLICK activity with simulate click property enabled in the property panel
For more details on activate activity

Cheers @sam.lee

But the Activate activity should indicate on which screen? the ‘Download’ button or the IE Notification bar ?

1 Like

Use Activate activity and click the IE Notif bar

We need to select the notification bar as a element in ACTIVATE ACTIVITY
Cheers @sam.lee

I just ran the robot in the background and the Activate activity reaches the timeout, it failed.

When I ran, I locked my computer and let the robot execute in the background.

Were simulate click property in the property panel of click activity is enabled
Kindly check that once
Cheers @sam.lee

Yes, all Click activities is in Stimulate Click

Kindly select the simulate click property.

All Click activities is in Stimulate already

Fine in ACTIVATE activity set the DelayBefore property with a millisecond value around 5000 milliseconds
And in WaitForReady property set as Complete and then try once
Cheers @sam.lee