Unable to click/type into a popup window

Hello,

After reading many topics/threads about how to handle a pop-up and trying out many different ways, I am still unable to click and type into it. I am using IE and UIPath version 19-06.0.

Scenario: I need to create user and when I click on “Copy User”, it opens a pop-up with no URL. I need to type in several information in the fields and click on “Finished”. My flow then stops and throws an error that it is unable to find the element.

What I’ve tried so far:

  1. Attaching a window and clicking on the element
  2. Attaching a browser and clicking on the element
  3. Recording and clicking on element

None of the above worked. Can you please help and let me know how to proceed?

Share your workflow or screenshot

Try using “Activate” activity which will enables you to activate the UI element

1 Like

Hi Parth,

Please see below.

Inside the sequence, I put an Open Browser activity and then afterwards it will search for a user. It works fine until the pop-up comes and the the flow stops with an error that it cannot find the element.

uipath_sample2|690x388

Thank you.

Hi keerthims,

Thanks for your answer. I tried using the “Activate” but it’s still not recognizing the element (pop-up). I’ve put it inside the “Open Browser” activity and also tried putting it outside but still doesnt work.

Thank you.

1 Like

Hi,

I was able to make it work by editing the Selector and putting a wildcard so it continues to the pop-up window.

Thank you all.

@kimuhm
Please mark it as a solution so that if anyone looking like this kind of solution it will help them also.
:+1: Enjoy Automation

Thanks,
Parth

1 Like

Hi @kimuhm
use Attach window activity and put click and type into activity inside it before that indicate the screen of that pop window foe attach window activity.

2 Likes

this worked for me… thanks

Hi I @kimuhm Can you plz guide me how did you do that? Its been almost 6 hrs I m trying to solve this issue

Hi Jasmine,
Were you able to get a solution for this?
Would really appreciate a reply.

Thanks

Hi Kimuhm,
Could you eloberate your solution?
Where did you put the wildcard? In the app name?
Would really appreciate your reply.

Thanks.

Can anyone provide a step-by-step to resolve this issue either by entering a wildcard into the selector or using activate window. No matter what I try for this type of issue in Studio X, nothing works! Thanks!