Level 3 assignment 2 - Pop-up window interaction

I try to interact with the pop-up window after pressing the update work item button but I can’t click or type into the pop-up window with selector. The pop-up browser seems inactive and there is an error about UI element not found based on the given selector.

Methods that I have tried: delay, get active window and attach window, attach browser, click image (the pop-up browser become active but I still can’t type into the textarea)

May any suggest a way that I don’t have to close the main browser to complete the type into action on the textarea of the pop-up window.

This should work fine in IE.

Have you checked whether your attach is within the main IE attach. You may need to separate them out. I would suggest creating a separate workflow and just record the task you which to complete.

RD

@karlkong: Please use the UiExplorer to access the UI elements, that’s the way to go about selectors.

They are attached to different browser under a different scope.
I have tried to make the sequence separated but it doesn’t work still.

The selectors of the two browsers are similar. Will this affect the attachment result? Any other workaround available?
image

any one help me

Hi @Blue_prism_Guruji,
Try resetting the data in acme.

Regards,
Jyotsna

I’ve attached to the pop up window with the following selector details :

<html htmlwindowname='WI-Update' title='ACME System 1 - Work Items' url='https://www.acme-test.com/work-items/update/*' />

Any resolution I am facing similar issue.

The selector does not help for me-> <html htmlwindowname=‘WI-Update’ title=‘ACME System 1 - Work Items’ url=‘https://www.acme-test.com/work-items/update/*’ />

Hi,

I am working in Chrome.

I am also stuck at this same place where the popup window is not getting selected, and TYPE INTO activity is not working instead the component selection error. Is the academy know about this issue? If many are facing the same issue, any body able to complete the task?

Completed people could you please provide a resolution?

Regards
Khaleel

update the selector for attach browser as shared in screen shot and then use Type into activity by selecting

cheers

Simply add - idx = ‘2’ just after the title. Hope this assist. In similar selectors, Idx plays important role. Hope this will work. Worked for me.

image

Hello everyone, I made this little solution, I hope it works for you,

@Geovanni07 helped and shared the problem,

regards,

Main.xaml (15.7 KB)

1 Like

Hi armando!
Just wanted to let you know that this worked out for me. Maybe not the neat solution I was looking for the last couple of hours, but the only one I found so far that actually works with chrome… If anyone finds a better way to do this please reply. There’s gotta be some nice way of setting up those selectors in chrome??

Anyways, thanks!

/ Rikard

Try with IE browser

Yeah I know it’s easier with IE, but I don’t want to use that.