UiRobot run in Remote desktop


I can run my tasks in UiRobot inside the RDP. Here BOT run without orchestrator. Tasks are continue when I minimize RPD window. But when I close or disconnect RDP from my computer, the BOT do not continue its tasks and finally show a timeout exception and BOT is stops. How to continue BOT run in RDP when it disconnect from local machine.


In case of attended bot… it will not work when we disconnect from RDP. because bot will require windows active session.


Actually for both unattended and attended, when you disconnect your RDP session it interrupts UiRobot. So basically if you RPD into a session with a running process, don’t close it or it will stop it. If you would like it to run without you having an RDP session open, then start the job from Orchestrator while you are not in the RDP session and it will work. But as soon as you enter that logon session with RDP you can’t close it cause it stops the process… and I am not sure if there is a network configuration to change that.





Try to Invoke your workflows using ‘Launch Workflow Interactive’ activity, It works even when your are into an RDP session and your minimize the RDP. Not sure if there are any drawbacks of using it. I have seen it working in most of the case.

Let me know if it works for you as well.

Rammohan B.


Minimize RDP is working fine. I modify registry by https://robot.uipath.com/docs/executing-tasks-in-a-minimized-rdp-window. I need Robot continue its task after disconnect RDP from my computer. There is any solution to continue robot task without connect RDP from my computer