Problem with unattended robot and browser

Ah, ok. Changed URL to another site, page still loading when I connect via RDP, but after that, loaded immediately.

@shady2k

It’s weird. Then try with some other browser once and see.

With IE page is loading, but it can’t find input field. Is it Chrome issue?

@shady2k

May be you Developed workflow based on Chrome browser and you need to change selectors based on IE browser then only it should work.

Yes seems like issue chrome browser. Have you installed chrome extension from Uipath studio or not ?

Ok, but I won’t use IE.

Yes, extension is installed.

1 Like

I have the same issue but with IE. When robot is in unattended mode the page is simply not loading the full content. When starting a session manually with RDP works perfectly fine. I have added plenty of delays, doesn’t help.

I am having a similar issue running unattended bots from on premise orchestrator with IE. I have delays in the workflow however I either get could not communicate with browser or if it does open browser with a very long delay, it cant find the element that should certainly be there.

Also when I RDP to the machine I see that the bot has opened multiple windows during the workflow. However when I run it using studio on the server there is no issue.

I have a similar issue with Chrome on 2 different bots, VMs,
Bot cannot find and communicate with Browser in unattended mode.

1 Like

Hi Team,

Is there any solution for the above problem of web page is not loading in unattended mode?.

Regards,
Pankaj

I’m facing this issue too. Seems like it’s looking for a selector that isn’t present. oddly when I take a screenshot right before the activity, webpage is clearly visible but the UI element that works in attended is not visible in unattended job. However the suggested UI element from exception handling isn’t even available when I rdp in and try to debug in Studio…

Dear All

I also have this issue recently.
Uipath will have a hotfix ?
Or any best old version Chrome can try ?

Hi fellow UIPathers. I just wanted to pile on and say I have the same issue and have tried Chrome and Firefox which are my go to browsers. Has anyone tried Edge? I hope UIPath has a fix for this as it would be an issue if I always had to have a RDP session open on a laptop.

Forgot to add that the RDP is on Windows Server 2016 Standard 10.0.1493, UIPath Assistant on the RDP is 20.10.4.

On the UIPath forum I’ve seen a post regarding using tscon to disconnect from an RDP session but leave the GUI active. UiRobot run in Remote desktop
I’ve see a similar post here for different use case Disconnecting From Remote Desktop While Running Automated Tests | TestComplete Documentation

What I tried was from cmd as administrator, I ran “query session” to get my Session Name. Then ran " %windir%\System32\tscon.exe RDP-Tcp# NNN /dest:console" substituting my Session Name for “RDP-Tcp#NNN” e.g. %windir%\System32\tscon.exe rdp-tcp#35 /dest:console which kicked me out of my session as expected. Then from orchestrator I kicked of my job and the bot still hangs on browser input for username and password for my web app. I know that both username and password type into’s use simulate type and the click on login uses simulate click. But this doesn’t work, has anyone had any success with tscon.exe? Or anyway to get GUI interation to work while an RDP session is disconnected?

Best regards.

Allow me correct myself, using tscon.exe does work but it took some doing to go through my process and make sure every interactive activity was using either simulate click/type or send windows message. Also, just disconnecting from the RDP session did not work for me, I had to use the tscon.exe method to disconnect. For my robot in settings, the Login to Console had to be set to No. One of the feature that helped meet track down were the process was hanging up and timing out was to set the robot settings for Logging Level to Trace. Then in Automations => Logs, or for the Job, you can click on the more icon (the 3 vertical dots on the right) and click View Logs. Having the bot’s Trace on gave me the detail I needed to figure out where in my process I needed to change the click or type to simulate or windows message.

One other thing. As far as I can tell this only works for RDP. I tried with VMWare VDI and it doesn’t work. When I used query session got get the session name, the rdp-tcp session name has no #number on it and tscon.exe doesn’t like it. I believe if seen there’s some VDI settings that can be tweaked but in my environment I need to get some admins to help me out with that.

Hope this helps anyone who had been struggling with running their bots totally unattended.

1 Like

Hello, any solution here? :S

Hello, any solution here? :S

Hello everybody! I have possible solution for your case:

As far as I understood, when Orchestrator open RDP session to unattended bot machine - it don’t use hardware acceleration. As you can find on some other forums, in this case Chrome could not working properly, as it using gpu by default.

You can try to find gpu settings at chrome://flags/ and also try to run chrome.exe with key --disable-gpu

Hope this will help to you!

Hello Valentin,

unfortunately this solution is not working for my process. Any other suggestions?

Thanks,
Eva

Hello Everybody,

I have the same problem too. I have solved the problem using IE but our system will not use IE anymore. That is why i have to migrate it to the chrome which is only compatible browser. We never update chrome since august 2019 by the way. Some websites or apps are working properly but many of them are not working properly.

Thanks for helping.

Hi All,

I faced the same problem, but just by adding “Minimize Window” and then “Maximize Window” functions helped me to avoid Chrome white screen