UiRobot and Community Version

Hi there!

I have a question, I wanna run a robot locally. what I did: I published my project and I runned from UiRobot but doesn’t work as I was expecting. Probably I should learn a bit more about that. but anyways I will ask If somebody could give me a light.

My robot read an excel and then do some tasks, at the end must to update that excel. So If I run this from Uipath studio I can see the updated excel, but If I run from Uirobot my excel is not updated. or probably it is but I can’t see it.

What I understand about that…maybe I’m wrong …if I published my project is like all the project is put inside a box right? the excel actually is inside the folder’s project. So I guess that the excel is updated insided that box, What should I do to see the last updated excel whn I run the project from Uirobot?

@carmen - If you have published your project, then you need to do the below steps in orchestrator.

  1. Create an environment
  2. Create a process in the environment
  3. Create a job

You can then run this job from Orchestrator. This is equivalent to running the project from UiPath Studio. And both should give the same result.

You can also do this from command line using the below as a reference.

Hope this helps!

thank you for your answer, but I don’t wanna use Orquestrator. I just wanna do locally. It is possible?

Yes, you can do this using the below command. e.g.

UiRobot -file “C:\UiPath\Project\Main.xaml”

Please check the URL below for more details on using arguments from command line.

that’s is not my problem. I need to know why if I run my project from Studio is different than running the same project using uiRobot.

I mean …why my excel file is update if I choose to run Studio and It is not updated if I use UiRobot.


Facing similar issue, can anyone explain how to check Versions of studio and robot using cmd prompt?
I got instructions as our client is having robot as enterprised licenced and studio as community is it possible to have so?

please clarify @ovi