UiPathRemoteRuntime from Azure server to windows RDP

I’m automating a SAP process in wich I need to open SAP from a Remote Desktop and when I run it on my personal PC it goes just as expected, but when I try to run the robot on the Azure server where it’s supposed to be run, I find the “Cannot automate, UiPathRemoteRuntime is not installed on…” got support, installed the RemoteRuntime.msi on both Azure server and Windows Remote Desktop but the robot just won’t run.

Any suggestions? Thanks in advance.

Hey @Daniel_Zarate

Even after installing the remote runtime, you are still getting the same error or a different one this time ?



  • Is it a citrix automation
  • Also, did you check the azure server IP address remains same or is it changing every time you access

Hi @Nithinkrishna I keep getting the same error, this one

Hi @ushu

The IP adress is the same every time I access

It says click for more information. Could you please do that and show what’s the error ?

When I click on it it redirects me to the UiPath page where it suggests to install the .msi, I’ve requested it, installed it both on the server it runs and on the RDP

Still won’t let me automate.


Sorry, server and RDP ?

Sorry I’ve just come back to the issue

Yeah the robot runs on a AZURE server and access a RDP where SAP is installed.

I’ve “solved” the issue making the SAP server not show a welcome screen, wich seemed to be outside the servers instance thus not allowing me to access the Runtime file


1 Like

Cool buddy :slightly_smiling_face::+1:, So thanks for sharing the work you have done ! It will help our community!