Unable to recognise RDP session elements

Hi all,

I’m experiencing some problems with rdp sessions where having installed RemoteRuntine in RDP server and also extension at local instance the robot is not able to recognize any element on the remote session.
I’m using an .rdp file that it is opdening directly a SAP B1 frontend, there is an alternative using RDWeb but with the same issue.
My UiAutomation.Activities is in sinc with the installed Remote Runtime (21.4.3 in both sides) and the process seems workign fine at the RDP server…
Did anyone faced the same troubles? How did you solved it?

Thank you all in advance!

Make sure that the Remote Runtime is as well installed on your robot machine too. I had similar issues and resolved it by installing the Remote runtime on my robot machine. Please refer to the following link Extension for Windows Remote Desktop

Thank you @Thrall. I’ve already checked it, I even reinstalled all at local level, but it is still not working. Is there any way to double check if it is correctly installed?

Thanks for the support.

Is your SAP running on Citrix? If yes, you will need Extension for Citrix Remote Desktop(on your Citrix server). If no please make sure that the Extension for Windows Remote Desktop installed on the machine that runs the SAP plus the machine that executes the robot or automation package.

P.S. There might be a condition that on your remote machine that hosts the SAP’s you only have a shortcut of SAP on your desktop, but the actual connection happens inside of another virtual/remote environment.

Hello @Thrall!! Thanks for your answer.
Remote server is using RDP, RemoteRuntime is installed and working in the same server where SAP is being launched.

image

The machine executing the robot seems also be working with the RDP extension, dll are present…

image

But process UiPathRemoteRuntime.exe is not running by default when I start the Studio tool… Do I have to start it manually?

Did you follow the guide and installed the Extension for Windows Remote Desktop? The files and DLLs are present that’s correct. But it doesn’t mean they have been installed.

You don’t need to start the UiPathRemoteRuntime.exe manually.

@Thrall Yes, I did. I tried both ways… installing from Studio and cmd. It is not clear to me if there is a way for confirming the correct installation.

Thanks for the support!!

Worked for me from CMD

Just something came to my mind. What version of the Studio/ Robot are you using? As the latest UiAutomation.Activities are not compatible with the older versions of the Studio/Robots.

UUAA

Hi @Thrall, thanks for your answer. I’m started using UiAutomation.Activities started using 21.4.3, after it was updated to 21.4.4 (Same version I have for Studio)