UiPath working differently in testing and production environment and in attended and unattended mode

Hello!

So we have a weird issue with our robot. We developed it in the development environment and tested it. Worked fine in both attended and unattended mode.

Then we put the robot to production and tested it while in attended mode (watched, while it was doing stuff), everything worked fine.

Then we tested it in the production in unattended mode and it seems to have huge issues performing the same tasks it does in every other mode completely correctly. It misses stuff, gets different fatal errors and skips steps.

The weirdest issue we have ran into is that in the logs it says “deleted the document” (the robot is used for deleting unnecessary documents that it recognizes from the metadata of the document management system), but somehow the document is still there! So even the logs and what actually happened are not in sync.

And as said, this only happens in production environment and in unattended mode.

Is it normal that there are different error when running the UiPath in unattended mode or what what may cause this kind of problematic behaviour. We have been having the issues for weeks now and no fixes seem to work. Thanks a lot!

Hi
welcome to uipath community
–if that works fine in development instance it would work for sure in production as well

–is the folder path mentioned correctly like if its hardcarded or is it obtained from any config

Cheers @Esa_Juntunen

Yup, the folder path is different for testing and production so that’s no issue.

Probably the weirdest thing to understand is that when we actually watch the production environment bot doing the stuff, it does it correctly. However, when we schedule it and put it into unattended mode and it runs in the background, it usually runs into a fatal error at some point early on when looking through the documents. So the problem comes up only when in unattended mode.

Any update on this issue?

I am also experiencing the same things with my bot project as it run fine in Development but when pushed to Production, it acts differently and doesn’t run properly.