Uipath web automation 22.10 error

Hi All,
Anyone can help on this? How to fix the issue?

image

Extensions in Chrome is enabled, buy always with the pops of reminder, and ui element is not able to use in the website.

Pops wording:

Cannot communicate with UiPath Platform

The native part of the extension is not configured correctly.
Re-install the extension from UiPath Studio.

Hi @Allen_Huang,

Please follow the steps below

Install From UiPath Studio

  1. Open Studio.
  2. Navigate to Home > Tools > UiPath Extensions.
  3. Select Chrome > Install.
  4. Open Chrome and navigate to chrome://extensions.
  5. Enable the UiPath Web Automation extension if needed.

Hi, both actions are ready, it was ok before, but now have problems.


image

Try to uninstall and install it again.

Dear,

Of course, I just tried again, still the same problem, have no idea what happened.

HI,

For now, can you check the following document?

Regards,

Hi @sangeethaneelavannan1

Check out this document

https://docs.uipath.com/studio

Regards
Gokul

Hello @Allen_Huang

You can try removing the uipath extension from chrome and chrome extension from studio.

Reinstall it again from studio and check how it works. Also you can do a restart of studio and chrome after the installation.

Thanks

Hi.

If it is important for something, I’m in the same situation, but I’ve noticed that the “ChromeNativeMessaging.exe” process is not running… may be because an antivirus (FortiClient) rule.

Can we start that process in another way, in order to UiPath communitate with Chrome?

Regards.

Actually I’m in the same situation the exe process is not running. What I’m doing now is to switch back to IE, the UI element is ok to use.

Well… Edge is in the same point: FortiClient/Antivirus Software (AVS) blocking the execution.
The AVS just detect a “cmd” call and blocks it; does not matter the browser type.

Hi, “more info”:

Talking with my system co-workers at the company, it seems this is a “kind of bug” from Fortinet.
It’s about an internal rule that blocks any attempt, from an extension, to launch/spawn other unmanaged processes, like “cmd.exe”.

Unfortunatelly, Fortinet does NOT have a solution for this issue, and it can NOT be customize in anyway, by the moment. The only “workaround” they suggest is to TURN OFF/DISABLE AntiExploit rules in FortiClient EMS.

If you do NOT disable EMS ruleset, you are in trouble! :joy:

For more info: https://www.reddit.com/r/fortinet/comments/tg6xbe/chrome_extension_getting_blocked_by_forticlient/

1 Like

Please check the Studio Version, it normally is 21 and the extension you are trying to install is 22.
Also check if you have another product from UiPath such as Task capture because task capture belongs to 22 release. Please get back to me so I can support you with this troubleshooting.