UiPath.Vision has stopped working

Great job, team! I have tried using CV Type Into Activity and it worked like a charm. However, I am getting the following error message

UiPath.Vision has stopped working

Every time I run the computer vision module, I am getting multiple pop ups with this error message though the action has been successfully completed. Any resolution for this?

Hi,

Have a look at Release Notes for computer Vision for Type Into it says

  • Typing in the second input box after a label usually fails.

The activities actually work. I tried using the Click Activity too. The activity is successful; however, I still get a popup saying “UiPath.Vision has stopped working”

I have changed the OCR engine to “Abby OCR.” I am not getting that error message now!

Thx for the feedback. If you could post a screenshot of the error message and what you were doing when you got it, we’ll investigate

I was using the type CV type into action to enter data in a Citrix application. While using Microsoft OCR I get the mentioned error message (screenshot given below); however, data is entered. I do not get this error when I use Abby OCR.

image

What is the very last thing you did when you got the error? Did you click indicate în the scope, or in type, or did you change something in the OCR?

This occurs with any activity that I use using Microsoft OCR. I have tried CV Click and CV Type Into. The action is completed; however, I get the popup (usually two of them) with the error.

I understand. But what exactly is the step that generates this error?

Any action done using computer vision generates this error.

For instance, when I use CV Screen Scope and indicate the Citrix screen, the image is captured successfully and I get the error message.

Once I click start (in studio), the automation runs and completes the task (CV Type Into or CV Click). Once completed, this error is generated.

I have given the details of the problem below. Hope it helps.

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: UiPath.Vision.Host32.exe
Problem Signature 02: 1.3.0.0
Problem Signature 03: 5c66c7c7
Problem Signature 04: UiPath.Vision
Problem Signature 05: 1.3.0.0
Problem Signature 06: 5c66c7bf
Problem Signature 07: 159
Problem Signature 08: 9
Problem Signature 09: System.NullReferenceException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Thx, we’ll look into it

If anybody else encounters this error, pls post here

Spark, is it fixed for you too if you switch to a different OCR engine?

Hi @Spark_robot,

I’m the lead developer working on the Vision component.
Can you help us track down this issue?
Please create a new key (folder) in the registry, under Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps\ called UiPath.Vision.Host32.exe.

And create the following keys:

  1. DumpFolder (REG_EXPAND_SZ) – Folder where dump should be created
  2. DumpCount (REG_DWORD) – Maximum dumps created before old dumps will be overwritten. The default is 10.
  3. DumpType (REG_DWORD) – Minidump (1) or Full dump (2). Use Full dump

You can see the image attached (feel free to use any kind folder of your choosing). You can also see the fullpath there

When the issue occurs again, try checking to see if there’s a dump file in your folder, and send it to us.

Thanks!

1 Like

Hi, Florin
I have uploaded the dump in the link below.

https://drive.google.com/open?id=1x8KFER-VC-v1_jQ4NAl_uC4RWF4dMnNt

1 Like

Hi @Baruch,

Thanks for the dump files.
It seems to be an issue with MODI, but the dump unfortunately doesn’t give too much details.

I created a debug alpha package with a potential fix. If you’re able, try installing this package, and run the activity again. If it crashes please send me the dump again, otherwise let me know so we can put out a patch release.
You can download it here: https://drive.google.com/file/d/1eEKnUAyoLS3mYyQXg2KuaNyuDkVHcVmI/view?usp=sharing

Once you’re done with the package, please discard it, as it is not an official and stable release.

PS: Does Microsoft OCR crash for any kind of OCR activity? Or just with Computer Vision?

Hi, Florin
The error did not occur while creating the activity after the new package was installed. The error occurred after I ran the activity. I have placed the dump in the link below.

https://drive.google.com/open?id=19ry6aoP3j08b8ac7VeuepUPu0sD05z43

Also, I have noticed this error only with Computer Vision activities.

Hi @Baruch,

Are you sure this is the right dump?
I’m seeing it reference the version 1.3.0. Please make sure the custom Vision package is installed directly into your solution. (Usually it’s downloaded behind the scenes as a dependency to UIAutomation).
The version should be 1.3.6995.28962 image

Please see here how to install a custom package using UiPath Studio, https://studio.uipath.com/docs/managing-activities-packages and let me know if you have any questions or there is anything else I can help out with.

Hi, Florin
I apologize for the delay. I have installed the new package and I am not getting the error while using Microsoft OCR. Thank you!

Regards,
Baruch George

Great.
We will include the fix in the next release.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.