Computer Vision / OCR configuration error


I wanted to test CV and paste a CV Scope in my workflow and directly got that error message:


How can I fix the error? What OCR configuration do I need to do?

Hi @Vapol

Welcome to uipath community buddy
make sure you have internet connection to make use of CV activities and check with your firewall settings, disable it and they try once
Cheers @Vapol

1 Like

There is an issue on our side. Most probably the problem is that the Scope selector is not finding it’s target app. Try indicating the scope again and see if it still happens

I have the same error. The Scope seems to work, because the Click works. But because of the OCR doesn’t work, the Click sees only icons, not text buttons. (it says: No unique anchor found.)

Pls provide versions for ComputerVison activities, Studio, UIAutomation package

Even a Robot Master has the same issue!
Some more info, if they help.

Main.xaml (23.6 KB)


Can you please try to set language for Microsoft OCR to “en” and see if it solves the issue?

No. It don’t help. Originally it was “en”. And I’ve tried all Scales from 1 to 10.

If you create a new project with the dependencies you’ve shown above, does it work?

We’re trying to get to the bottom of this but we can’t really reproduce it.

What does the content of the Scope look like, is it a whole window or just a small portion, like a textfield?

If you can describe all the steps to reproduce this, it would help.

The process is very simple, just for trying the activity.
Here are my steps:
Start new blank process. (Language: VB)
Install packages:
- UiPath.Vision 1.6.1
- UiPath.AI.ComputerVision.Activities 2.0.1
- UiPath.OCR.Contracts 2.0.0
- Json.NET 12.0.2
- UiPath 19.7.7128.27029

Launch Computer Vision (recorder).
Agree for T&C
Settings: paste ApiKey from UiPath Community edition

Close Recorder
Place CV Screen Scope Activity
Indicate the Scope to “” page on browser

The warning appeared:

Then placed the CV Get Text activity and the Message Box to show result.
The result is empty.

The process is also attached.
Main.xaml (93.2 KB)

I think there may be a problem with licenses. I’m using Community edition.

1 Like

what windows version are you using?

I have same error on Windows 7, Windows server 2012 (terminal mode)

I have the same issue on windows 7 with licensed Uipath on prem :frowning:

Try uninstalling “UiPath.Vision 1.6.1”, today i start having the same issue and i solved it uninstalling that package. Hope it helps!

Thanks @NotPana09. It works, at least with simplest activities for testing.
So I uninstalled UiPath.Vision 1.7.0. But it works only with Tesseract / Google OCR.
The default Microsoft OCR still has the error.
Is there any developer to fix it?

1 Like

Dear Tung,
Do you install Sharepoint Designer 2007 or not?.
Refer link.
What is your company name?. I come from VN also. :smiley:

It seems there is an issue with Microsoft Modi OCR on certain operating systems, mainly Win7. What OS are you running?

A much better alternative is to use Omnipage. It’s a new OCR that we just released and I think we’ll soon make it the default. it’s a separate package found on the main stable feed.


Do you have Sharepoint Designer 2007 installed, with the MODI module set to Run All from My Computer?

Please let us know so we can try to reproduce.



1 Like


Just try using another OCR Engine, I got the same issue and changed it to Tessaract and it worked