UiPath TestSuite - testing jobs are pending

publishing Test case to Orchestrator and executing From Orchestrator the Status is showing pending only

Thanks & Regards

Hi @srujana13a5,

You have tagged your question incorrectly. This is not a feedback post. You seem to be asking for help so you should have chosen “Help” as the category. This is important when you ask a question as not all forum members will read post made on the feedback tag. More eyes, higher is the chance of your question being resolved quickly.

That said, the error you get (pending) is due to incorrect license used on the robot. When you are running testing/test suite, you need to configure your testing robot.

If you want to run a test suite with Testing activities, your robot needs to be allocated a testing license. When the robot is not configured with testing license, you will see the process / test as pending in text executions.

In simple words, allocate a testing license to your robot and this will work just fine.

Hi @jeevith

I have given testing robot license 1 still getting same

Thanks & Regards

Hi @srujana13a5

If your user who has be allocated the testing license is busy performing other automations (other licenses), you can get a pending error as well.

  1. Check that the user is available
  2. Has the correct credentials to login to the testing robot machine
  3. Has the testing license allocated

My issue solved

Thank & regards

My user problem I solved thank you very much

@srujana13a5 : Would you like to share your solution for the community?