Test sets with test cases executed from orchestrator getting stuck in "pending" state in Uipath testing

Hi, I tried publishing my test cases to orchestrator, after which they appear on the site. Later I created a test set with some of the test cases. When I execute them, they show me that they are in pending state and remain like that. I tried waiting for a long time but no help. They don’t execute on my machine, they just stay in the pending state. When I execute the same test cases through UIpath locally from the studio, I can execute them normally without any issues. I want to execute them from the test tab of orchestrator.

I am using Uipath studio pro community licence.

Is there some step which I am missing or doing wrong? Please help.


Hi Clinton,
I am also having the same issue as you said and i am trying to get resolved in many ways but still am not able to find the right solutions from anybody. So if i could resolve this problem then will let you know and same time if you got solution please post me here or send email to mailsofrajeshd@gmail.com. Thanks!

Hello @clinton @Rajesh_Devan_Consultant,

The robot goes into Pending state mostly due to the type of license associated with the robot.

Under the management settings change the robot type to “Testing” and then save it.

This should resolve the issue.

Thank you manish.

Go to Orchestrator’s Management Tab ant then click on Robot then click on the three vertical dots on extreme right and then click on edit. Now change the type to Testing from the drop down. Also make sure you have assigned it to the proper environment.