Uipath Studio v 2020.4.4 Issue

Good Day,
I need help please.
I have my workflow package sitting in a mapped drive. My workflows have been working fine until today. issue is the file path is not found and this is the Error i am getting RemoteException wrapping System.IO.DirectoryNotFoundException: Could not find a part of the path ‘X:\Source\UipathFolder\project.json’ . when i run this from the local machine it works. Please assist how can i make the mapped drive work? Thanks

Hi @Caroline_Mozwenyana !
When you go to the path X:\Source\UipathFolder do you see the project.json file ? (don’t mind a screenshot :wink: )
Would you mind specifying your environment ? Like:

  • are you running your process from UiPath Orchestrator ? or from UiPath Assistant/Agent ? or UiPath Studio ? What is the version of it ?
  • is the path from the local machine the same as X:\Source\UipathFolder\project.json ?

Hi @Hiba_B

  1. The Json file is definitely there at the path. . Version of Uipath is V 2020.4.4.
  2. This fails when i run it using Orchestrator, uipath studio and when i run using Uipath Assistant.
  3. No the path on the local machine is different its on E:drive . I literally just copied the solution folder onto my E:drive and ran it from there. and it runs from the Edrive

Hope this makes sense. sorry i am also still new to this . Thanks

Ok, thanks for the details.
Still several things that we need to check:

  • in X:\Source\UipathFolder, would you mind going to “Display” in the windows explorer features and check the box “display extensions”, and retake the screenshot while leaving us see the the path ?
  • In X: open the Main.xaml file and tell us if you see any error message while opening the file and screenshot the error if displayed. If no error displayed, then run the bot in Debug mode and display us the screenshot of the error (what I am interested to see is when the error appears: before opening the file, when the bot in running, or when the bot imports everything before starting to run the code)
  • When you publish something to run a job in Orchestrator, the following path is where UiPath Assistant goes to run the bot: C:\Users\%USERNAME%\.nuget\packages\name_of_process\version_of_process\lib\net45\json_file, would you mind confirming us that you have this path, and see your json file there ? (by sending us a screenshot)