UiPath Insights install SSL not valid

I’m having issues trying to install UiPath Insights 2019.10.5 for Orchestrator 2019.10.20.

On the Insights machine, the installer complains on page 1 Insights Server Configuration due to seemingly invalid SSL certificate, but no further details given.

The ssl subject and website hostname is in the format of insightservername.companyname.com.au
The SSL cert is a domain cert authorized by the company’s certificate authority.

What could be causing the error?

Hello, i ran into the exact same issue and support helped me resolve it. The SSL cert must have a SAN.

Thank you @fernando321.

Having looked around the internet on the topic of SSL, I have a feeling that might be the case.

I did contact UiPath Support already and will hopefully confirm this soon.

Hello @drkeek,

I have also seen this issue when there are two certificates in the personal store with the subject name but used for different purposes such as client authentication or server authentication. If the subject name is the same, the installer does not have a way to differentiate the two and will not know which is the one you’d like to use.

Good to know @Adrian_Zielinski.

Knowing this certainly help out as well.
I have tried installation with SSL cert that has a SAN for the Insights and it no longer complains on step 1 above.

The install still failed and right now I’m thinking the issue is with SSL cert for the orchestrator which also didn’t have a SAN. It’s a wildcard SSL.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.