UiPath Extension for firefox not working

I have being trying to automate browser based activity with UiPath 2020.2.0 beta 108. I am using Firefox for the same. Two days back the program was running completely fine. But now it is showing me error “Open Browser: Cannot communicate with the browser, please check the UiPath extension.” I have tried all the suggested steps to rectify it(1. Restarting the browser. 2. Removing the extension and adding again. 3 Tried in both 32 bit and 64 bit firefox. 4. Checking the Registry Edit). Still I am getting the same error.
Please help.

is ensured that uipath extension is allowed to be active in Firefox private modus?
you can check and reconfigure in FF, just type about:addons into the adress bar and check the UiPath Addon and its settings

@ppr Thanks for the reply. I checked allow for private mode in add-on. Still getting the same error.

Hi @shreearchita

Did anything change as far as the browser is concerned? What is the version of your Firefox?

Hi @loginerror
Version for firefox is 74, 64bit.
I got a new issue: it is not able to communicate with other browsers as well.


Can you share a screenshot of your chrome and firefox on task manager ?

Yes. Shared the screenshot. Firefox is 32 bit but I have tried in 64 bit also.

1 Like


As i unterstand, you already installed the extension on both chrome and firefox right ? And still you can’t use UiPath on both of them right ?

Have you tried on IE ? Also check if you have something like this on your chrome :point_down:


Few more things to try:

  • update all activity packages to the latest versions (20.2.0)
  • if all else fails, try to reinstall Studio from scratch

Yes you are right. Even after installing extension it didn’t work. In IE, it is telling that uipath can’t communicate with the browser

1 Like

I have reinstalled UiPath, still getting same error.

1 Like


Please, share a screenshot of your Chrome… as mentioned before, on my previous post…