Open Browser (Firefox): Cannot communicate with the browser, please check the UiPath extension

Yesterday UiPath could open up a tab in Firefox and select an item. Today, it opens the browser but won’t do any activity in the body. It only says:
“Cannot communicate with the browser, please check the UiPath extension.”
I have installed the extension around 18 times but I always get the same error.
I followed Ander’s tutorial on the problem, but still get the same error.

If I choose IE in the properties tab, IE works fine and executes items in the body.
I have reverted to previous versions of firefox (v. 80.00, v 88.00) but that didn’t help either. I don’t understand why this basic function stopped working.
Any suggestions or ideas on other things I can do to solve this problem?
Thank you in advance.

1 Like

SOLVED:
Using the advice from another thread I:

  1. I added an 'Open Application" activity instead of ‘Open Browser’. I then chose the Firefox browser. Next I got a new error: “Cannot find UIElement.” It was great to get a new error!
    Then I reverted back to ‘Open Browser’ Activity, chose Firefox and now everything works.
    Thank You!