UIPath Deployment

I am new to uipath. I am trying to deploy the developed XAML files in the https://platform.uipath.com, but i am not able to do it. I have checked some of the videos and tried, but not able to perform the process which was mentioned in the videos. Could anybody help me on this. I am currently using trail version of UiPath studio and the version which I am using is If it would be a desktop sharing session, it would be more helpful for me.


Are you getting any error during publish, if so provide screenshots.

Or you are trying to say that you don’t know how to publish.

hey @issqfortest ,
Can u just elaborate your problem??
Do u want to publish your workflow to the orchestrator Or u are getting some issue while publishing??



Thanks a lot for your quick support.

I have tried deploying but not able to do it. I have published and also tried to upload the package but it is showing error. Attached are the screenshots.


2nd Image


3rd Image3


Could you please help us on this.


I am trying to deploy the workflow.

Hi @issqfortest

The Status on your UiRobot is showing that you’re connected, but in your orchestrator it seems like you’re disconnected.

So I think you are connected to another instance of orchestrator, not the one you’re logged on to.

To solve this problem you should go to machines and click on details and then copy the machine key, and paste it into your UiRobot config and reconnect again.



I have copied the key from machine details and pasted in the UIRobot config. Attached is the screenshot for your reference.


But still the robots are showing in disconnected mode.

Are you sure you gave the right info when you were configuring the robot.


Are you entered correct username and domain name in provisioning robot ?

If not then Goto cmd prompt and type ‘whoami’ and it will give your system domain name and username then enter it there.

Yesi have provided the correct username and domain in provisioning robot. Below is the screenshot.


I think domain name is case sensitive and try with caps once.


I have tried to replace Domain\Username with CAPS, but still in the Disconnected mode.

I have tried replacing Domain\Username with CAPS, but still in the Disconnected mode.

I have created a job, it ran manually but when i am trying to run the job by scheduling the job it is not running. Could anybody please help me on this issue.

I am not able to get the UiPath.Models.OrchestratorJob in the Type Argument of ‘Get Jobs’. Could anybody please help me on this issue.