UiDemo Walkthrough - Does not perform anything after login into UiDemo

Hello, I have completed UiDemo Walkthrough as per the pdf file and some help from community posts.

When I run the Main.xaml file, the program logs into the UiDemo using credentials from the Orchestrator, main UiDemo screen opens, but no further action is taken, program just keeps waiting.

I have attached my complete file, please check and advise where I am going wrong.

ReFrameWork_UiDemo.zip (1.7 MB)

HI @yusufht

I don’t see the attached file… can you try attaching it again…

Please check now, zip file attached

can see now… I will check and let you know…

Hi @yusufht

I don’t see any problem with the workflow. Can you try this execution method.

Navigate to this point

right lick on this activity and add a break point… Then go back to the main flow and run the entire process in Debug Mode. This way, you will be able to run the entire execution step by step manually… This will help identifying what the problem is… Can you try this and let me know if it hangs in some place or if it throws any error at a particular activity?

Hello, I tried above,

I get an error message saying that Loading Asset UiDemoPath Failed

Screenshots attached - Error and My Orchestrator page.

I guess right now there is a problem with the orchestrator as well. It is not loading for me… this could be the reason here… try refreshing your web page… im having the same issue…

looks like its working again now… can you try the same again and see what happens this time

Tried executing program in debug mode again, as far as what I understand, it worked perfectly till this point.

I have attached screenshot.

Continue the execution further… until it the Demo opens and to the point where you try to insert values to those text boxes CashIn etc… let’s see whether it gets into any errors to understand why it was doing nothing earlier…

Tried running the whole program in debug mode.

Seems like, program is unable to fetch any transaction data from the Orchestrator (Screenshot attached). What should I do?

I have re-checked my queue name in both Orchestrator and Config file.

Also, the Orchestrator queue has about 106 items.

In the queue, can you check whether there are any records with the status “New”?

like this:

I tired editing GetTransactionData.xaml

Still does’nt work.

All of them are Successful in the orchestrator queue.

If all of them are in Successful state, that’s why you are not getting any records to process :slight_smile:

The records in the queue should be in New status for the program to get records because Get Transaction Item gets all records under the status New.

So what you can do here is, You can repopulate the queue with your dispatcher program you wrote for the UiDemo practice. Repopulate the queue, and run your program again to get the records from the queue. This will solve your problem :slight_smile:

After running the dispatcher program to repopulate the queue, I prefer you run this same solution in the debug mode just to see how things go rather than just running it. The debug mode gives you the exact picture of what really is going on…


Thank you very much for your time and effort - worked perfectly now.

Program processed all 106 entries and then closed UiDemo. Please help me with following 2 doubts

  1. What result am I supposed to get after program execution? Where can I see the result.

  2. Why was program unable to process Successful queue items, but perfectly processed all New queue items?

Cool… :slight_smile:

These are my answers for your two doubts

In the REFramework, you will not see any message box saying the execution has ended. However, you can see the status of the currently executed solution by going through the logs from the Output panel of the Studio. If you have published the solution to Orchestrator and ran it from there, then you can see the status along with the logs in the Orchestrator Jobs page.

When a transaction gets processed once, it will not get processed again. So, if a transaction gets processed successfully, the status of that will get changed to Successful through the framework execution. That’s why you were unable to get the records with the status Successful. The queue should have items with the status New to be processed. You can read more on these statuses in here…

Please also mark the appropriate answer as the solution so that it could help others with similar problems as well :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.